summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mined/mined-2000.16.ebuild')
-rw-r--r--app-editors/mined/mined-2000.16.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/app-editors/mined/mined-2000.16.ebuild b/app-editors/mined/mined-2000.16.ebuild
index 532c87c64..a490d7765 100644
--- a/app-editors/mined/mined-2000.16.ebuild
+++ b/app-editors/mined/mined-2000.16.ebuild
@@ -2,17 +2,29 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=2
-inherit base
+inherit base toolchain-funcs
DESCRIPTION="Text editor with extensive Unicode and CJK support"
HOMEPAGE="http://mined.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+SRC_URI="http://towo.net/mined/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DOCS=( "README" "CHANGES" )
+DOCS=( README CHANGES )
+
+src_prepare() {
+ default
+
+ # Disable stripping and supply the correct compiler
+ # we can't just pass CC as upstream uses it as a keyword-var
+ sed -i -e '/strip/d' -e "s/\$(CC)/$(tc-getCC)/" src/mkinclud.mak || die
+}
+
+src_compile() {
+ emake OPT="${CFLAGS}" || die
+}