summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cminpack/cminpack-1.0.3.ebuild')
-rw-r--r--sci-mathematics/cminpack/cminpack-1.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-mathematics/cminpack/cminpack-1.0.3.ebuild b/sci-mathematics/cminpack/cminpack-1.0.3.ebuild
new file mode 100644
index 000000000..93860382e
--- /dev/null
+++ b/sci-mathematics/cminpack/cminpack-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Software for solving nonlinear equations and nonlinear least squares problems"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack.html"
+SRC_URI="http://devernay.free.fr/hacks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dolib.a libminpack.a || die
+ insinto /usr/include
+ doins {,c}minpack.h || die
+ dodoc readme{,C}.txt || die
+}