summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-6.7.1-r3.ebuild')
-rw-r--r--sys-devel/gdb/gdb-6.7.1-r3.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sys-devel/gdb/gdb-6.7.1-r3.ebuild b/sys-devel/gdb/gdb-6.7.1-r3.ebuild
deleted file mode 100644
index 988a363..0000000
--- a/sys-devel/gdb/gdb-6.7.1-r3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-PATCH_VER="1.3"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sourceware.org/gdb/"
-SRC_URI="mirror://gnu/gdb/${P}.tar.bz2
- ftp://sourceware.org/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd"
-IUSE="nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- sys-libs/readline"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- ! use vanilla && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- strip-unsupported-flags
- econf \
- --disable-werror \
- --with-system-readline \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}