summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2013-10-10 09:35:44 +0400
committerAndrew Savchenko <bircoph@gmail.com>2013-10-10 09:35:44 +0400
commit227aa84c71bfb1e8d01d0dc18fe0fd5c1ef67ff0 (patch)
tree4247c8b7910188190a0fe4faa797f95f2f426a96
parentmediastreamer-ilbc: revision bump due to added slot dep (diff)
downloadvoip-227aa84c71bfb1e8d01d0dc18fe0fd5c1ef67ff0.tar.gz
voip-227aa84c71bfb1e8d01d0dc18fe0fd5c1ef67ff0.tar.bz2
voip-227aa84c71bfb1e8d01d0dc18fe0fd5c1ef67ff0.zip
mediastreamer-ilbc: add missing ebuild
-rw-r--r--media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3-r1.ebuild b/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3-r1.ebuild
new file mode 100644
index 0000000..b653a33
--- /dev/null
+++ b/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3.ebuild,v 1.5 2013/04/02 20:56:39 ago Exp $
+
+EAPI="5"
+
+inherit multilib
+
+MY_P="msilbc-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add iLBC support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="20ms-frames"
+
+RDEPEND="dev-libs/ilbc-rfc3951
+ >=media-libs/mediastreamer-2.0.0:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # dev-libs/ilbc-rfc3951 does not ship pkgconfig .pc file,
+ # so these variables should be set here to satisfy configure
+ ILBC_CFLAGS="/usr/include" ILBC_LIBS="/usr/include -lilbc" \
+ econf \
+ $(use_enable 20ms-frames)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}