summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2013-07-17 17:43:03 +0400
committerNikoli <nikoli@lavabit.com>2013-07-17 17:43:03 +0400
commit2d844430cd696d4cbb076094d30100f5b14b8623 (patch)
tree6d5b6e6676072b2e9017bcc403773d6d57d0d41a /dev-libs
parentdev-libs/weston: fix deps and USE flags, rm .la, cosmetics, add suid and syst... (diff)
downloadx11-2d844430cd696d4cbb076094d30100f5b14b8623.tar.gz
x11-2d844430cd696d4cbb076094d30100f5b14b8623.tar.bz2
x11-2d844430cd696d4cbb076094d30100f5b14b8623.zip
dev-libs/weston: install README.gentoo, weston-gears and examples
Package-Manager: portage-2.1.12.2 RepoMan-Options: --force
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/weston/files/README.gentoo9
-rw-r--r--dev-libs/weston/metadata.xml1
-rw-r--r--dev-libs/weston/weston-1.2.0.ebuild47
-rw-r--r--dev-libs/weston/weston-9999.ebuild47
4 files changed, 96 insertions, 8 deletions
diff --git a/dev-libs/weston/files/README.gentoo b/dev-libs/weston/files/README.gentoo
new file mode 100644
index 00000000..ed8c5c3b
--- /dev/null
+++ b/dev-libs/weston/files/README.gentoo
@@ -0,0 +1,9 @@
+For running Weston you need to have $XDG_RUNTIME_DIR in your environment,
+directory must exist and have correct permissions. If you are not using systemd,
+it will not be created automatically, you can create it using your shell,
+add these lines to ~/.bash_profile:
+
+# wayland
+export XDG_RUNTIME_DIR=/tmp/.runtime-${USER}
+mkdir -p "${XDG_RUNTIME_DIR}"
+chmod 0700 "${XDG_RUNTIME_DIR}"
diff --git a/dev-libs/weston/metadata.xml b/dev-libs/weston/metadata.xml
index 9cc71a2e..93fc89a8 100644
--- a/dev-libs/weston/metadata.xml
+++ b/dev-libs/weston/metadata.xml
@@ -8,6 +8,7 @@
<flag name='egl'>Enable EGL support.</flag>
<flag name='fbdev'>Enable fbdev backend.</flag>
<flag name='headless'>Enable headless backend and a noop renderer, mainly for testing purposes.</flag>
+ <flag name='pango'>Install examples which require <pkg>x11-libs/pango</pkg>.</flag>
<flag name='rdp'>Enable Remote Desktop Protocol compositor support.</flag>
<flag name='resize-optimization'>Increase performance, allocate more RAM. Recommended to disable on Raspberry Pi.</flag>
<flag name='rpi'>Raspberry Pi GPU support.</flag>
diff --git a/dev-libs/weston/weston-1.2.0.ebuild b/dev-libs/weston/weston-1.2.0.ebuild
index 520b6252..bd366021 100644
--- a/dev-libs/weston/weston-1.2.0.ebuild
+++ b/dev-libs/weston/weston-1.2.0.ebuild
@@ -24,11 +24,13 @@ LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
[[ ${PV} == 9999* ]] || \
KEYWORDS="~arm ~amd64 ~x86 ~arm-linux"
-IUSE="colord +drm +egl headless fbdev rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
+IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
REQUIRED_USE="
drm? ( egl )
fbdev? ( drm )
+ pango? ( examples )
+ pdf? ( examples )
rpi? ( !drm !egl )
wayland-compositor? ( egl )
"
@@ -59,6 +61,13 @@ RDEPEND="
>=x11-libs/cairo-1.11.3[opengl]
media-libs/glu
)
+ examples? (
+ pango? ( x11-libs/pango )
+ pdf? (
+ app-text/poppler
+ dev-libs/glib:2
+ )
+ )
rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
rpi? (
>=sys-libs/mtdev-1.1.0
@@ -118,10 +127,18 @@ src_configure() {
$(use_enable tablet tablet-shell)
$(use_enable xwayland)
$(use_enable xwayland xwayland-test)
- # required for tests
- $(use_enable test simple-clients)
- $(use_enable test simple-egl-clients)
)
+ if use examples || use test; then
+ myeconfargs+=(
+ --enable-simple-clients
+ $(use_enable egl simple-egl-clients)
+ )
+ else
+ myeconfargs+=(
+ --disable-simple-clients
+ --disable-simple-egl-clients
+ )
+ fi
autotools-utils_src_configure
}
@@ -132,3 +149,25 @@ src_test() {
autotools-utils_src_test
}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc "${FILESDIR}"/README.gentoo
+
+ cd "${BUILD_DIR}" || die
+ use egl && newbin clients/gears weston-gears
+ if use examples; then
+ use egl && newbin clients/simple-egl weston-simple-egl
+ use pango && newbin clients/editor weston-editor
+ use pdf && newbin clients/view weston-view
+ local i
+ for i in calibrator clickdot cliptest dnd eventdemo flower fullscreen image resizor simple-shm simple-touch smoke transformed; do
+ newbin "clients/${i}" "weston-${i}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "You may need to edit ~/.bash_profile, read /usr/share/doc/${PF}/README.gentoo*"
+}
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 520b6252..bd366021 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -24,11 +24,13 @@ LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
[[ ${PV} == 9999* ]] || \
KEYWORDS="~arm ~amd64 ~x86 ~arm-linux"
-IUSE="colord +drm +egl headless fbdev rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
+IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
REQUIRED_USE="
drm? ( egl )
fbdev? ( drm )
+ pango? ( examples )
+ pdf? ( examples )
rpi? ( !drm !egl )
wayland-compositor? ( egl )
"
@@ -59,6 +61,13 @@ RDEPEND="
>=x11-libs/cairo-1.11.3[opengl]
media-libs/glu
)
+ examples? (
+ pango? ( x11-libs/pango )
+ pdf? (
+ app-text/poppler
+ dev-libs/glib:2
+ )
+ )
rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
rpi? (
>=sys-libs/mtdev-1.1.0
@@ -118,10 +127,18 @@ src_configure() {
$(use_enable tablet tablet-shell)
$(use_enable xwayland)
$(use_enable xwayland xwayland-test)
- # required for tests
- $(use_enable test simple-clients)
- $(use_enable test simple-egl-clients)
)
+ if use examples || use test; then
+ myeconfargs+=(
+ --enable-simple-clients
+ $(use_enable egl simple-egl-clients)
+ )
+ else
+ myeconfargs+=(
+ --disable-simple-clients
+ --disable-simple-egl-clients
+ )
+ fi
autotools-utils_src_configure
}
@@ -132,3 +149,25 @@ src_test() {
autotools-utils_src_test
}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc "${FILESDIR}"/README.gentoo
+
+ cd "${BUILD_DIR}" || die
+ use egl && newbin clients/gears weston-gears
+ if use examples; then
+ use egl && newbin clients/simple-egl weston-simple-egl
+ use pango && newbin clients/editor weston-editor
+ use pdf && newbin clients/view weston-view
+ local i
+ for i in calibrator clickdot cliptest dnd eventdemo flower fullscreen image resizor simple-shm simple-touch smoke transformed; do
+ newbin "clients/${i}" "weston-${i}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "You may need to edit ~/.bash_profile, read /usr/share/doc/${PF}/README.gentoo*"
+}