summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-01-12 10:34:18 -0800
committerMatt Turner <mattst88@gmail.com>2015-01-12 10:34:18 -0800
commit8600f437b69d409827666d21a246b10e3e944796 (patch)
tree6db3c7371828db4b035b0b0a4742fc16edd21c39 /media-libs
parentx11-drivers/ati-drivers: make bundled libva driver installation optional (diff)
downloadx11-8600f437b69d409827666d21a246b10e3e944796.tar.gz
x11-8600f437b69d409827666d21a246b10e3e944796.tar.bz2
x11-8600f437b69d409827666d21a246b10e3e944796.zip
media-libs/mesa: Sync with main tree.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index dffd9220..3d88dd83 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -51,13 +51,14 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+nptl opencl osmesa pax_kernel openmax pic r600-llvm-compiler selinux
- vaapi vdpau wayland xvmc xa kernel_FreeBSD"
+ +udev vaapi vdpau wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
d3d9? ( gallium dri3 )
llvm? ( gallium )
opencl? (
gallium
+ llvm
video_cards_r600? ( r600-llvm-compiler )
video_cards_radeon? ( r600-llvm-compiler )
video_cards_radeonsi? ( r600-llvm-compiler )
@@ -96,6 +97,7 @@ RDEPEND="
classic? ( app-admin/eselect-mesa )
gallium? ( app-admin/eselect-mesa )
>=app-admin/eselect-opengl-1.3.0
+ udev? ( kernel_linux? ( >=virtual/libudev-215:=[${MULTILIB_USEDEP}] ) )
>=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
gbm? ( >=virtual/libudev-215:=[${MULTILIB_USEDEP}] )
dri3? ( >=virtual/libudev-215:=[${MULTILIB_USEDEP}] )
@@ -120,7 +122,7 @@ RDEPEND="
>=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
) )
)
- >=sys-devel/llvm-3.3-r3:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
)
opencl? (
app-admin/eselect-opencl
@@ -152,8 +154,8 @@ DEPEND="${RDEPEND}
video_cards_radeonsi? ( sys-devel/llvm[video_cards_radeon] )
)
opencl? (
- >=sys-devel/llvm-3.3-r3:=[${MULTILIB_USEDEP}]
- >=sys-devel/clang-3.3:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
+ >=sys-devel/clang-3.4.2:=[${MULTILIB_USEDEP}]
>=sys-devel/gcc-4.6
)
sys-devel/bison
@@ -322,6 +324,7 @@ multilib_src_configure() {
$(use_enable gles2) \
$(use_enable nptl glx-tls) \
$(use_enable osmesa) \
+ $(use_enable !udev sysfs) \
--enable-llvm-shared-libs \
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \