summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-01-19 22:24:06 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2014-01-19 22:24:06 +0400
commit1a2c18850cfb94a8053a7cb42ad233e32d0598b9 (patch)
tree7d900d2dd8e6415b57ca5b5706f41e98d4e944ae /x11-libs
parent[x11-proto/xcb-proto] Version bump per bug #496800 and bug #496802 (diff)
downloadx11-1a2c18850cfb94a8053a7cb42ad233e32d0598b9.tar.gz
x11-1a2c18850cfb94a8053a7cb42ad233e32d0598b9.tar.bz2
x11-1a2c18850cfb94a8053a7cb42ad233e32d0598b9.zip
[x11-libs/libxcb] Version bump per bug #496800 and bug #496802
Package-Manager: portage-2.2.8
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
new file mode 100644
index 00000000..584dc6e5
--- /dev/null
+++ b/x11-libs/libxcb/Manifest
@@ -0,0 +1 @@
+DIST libxcb-1.10.tar.bz2 475211 SHA256 98d9ab05b636dd088603b64229dd1ab2d2cc02ab807892e107d674f9c3f2d5b5 SHA512 c29ab5027498635d58fd7bfcd77899a406116b25fa8c4ec6513fc1395d8a0f99f602ad20b507660a62000b6fc879860d182cafd29af590e8b14f55150a064f7a WHIRLPOOL 4e11ffa276ef717e8f14183385413b30b52e8848669bf0f3075fb82adf4a4e94d8a98a2505797be055ff9f546e4fc11e94ba148099b6a0c2998da3e0f20fe99a
diff --git a/x11-libs/libxcb/libxcb-1.10.ebuild b/x11-libs/libxcb/libxcb-1.10.ebuild
new file mode 100644
index 00000000..0edfff49
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE=xml
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit python-any-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="selinux xkb"
+
+RDEPEND="dev-libs/libpthread-stubs[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ $(python_gen_any_dep \
+ ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+
+python_check_deps() {
+ has_version ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ $(use_enable xkb)
+ --enable-xinput
+ )
+ xorg-2_src_configure
+}