summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-04 22:50:37 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-04 22:50:37 +0200
commit3f6a1571eae610d89c9f7ebc71ccdbbfe0545e46 (patch)
tree6154388aba79bc38b29bf4bc071d1ba1b9e15f56 /x11-libs
parentx11-base/xorg-server: remove ia64 broken patch (diff)
downloadx11-3f6a1571eae610d89c9f7ebc71ccdbbfe0545e46.tar.gz
x11-3f6a1571eae610d89c9f7ebc71ccdbbfe0545e46.tar.bz2
x11-3f6a1571eae610d89c9f7ebc71ccdbbfe0545e46.zip
x11-libs/libxcb: bump 1.11
Signed-off-by: David Heidelberger <david.heidelberger@ixit.cz>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.11.ebuild49
-rw-r--r--x11-libs/libxcb/libxcb-9999.ebuild6
3 files changed, 53 insertions, 3 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
new file mode 100644
index 00000000..c26cc7ff
--- /dev/null
+++ b/x11-libs/libxcb/Manifest
@@ -0,0 +1 @@
+DIST libxcb-1.11.tar.bz2 517700 SHA256 03635d70045b9ede90778e67516135828a57de87ac508f987024f43c03620ff7 SHA512 718f9a44a621daae93eb94dc7b795743253c801ea98efd2041794823fdc8f5eeb031b1fa7d34b72e7a8fccf850d98f2373a49927c8d3198c1d4850af6ae14bb1 WHIRLPOOL 11e9bf3445977570884006de01a2ed44caf273c27d7d9908307cc81d82bba9995de6a0a3c3ef62bd9a06f56e977310616dc7eda909409d199b52305b2b4b0e36
diff --git a/x11-libs/libxcb/libxcb-1.11.ebuild b/x11-libs/libxcb/libxcb-1.11.ebuild
new file mode 100644
index 00000000..450d7cf8
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_REQ_USE=xml
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit python-any-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="selinux xkb"
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep \
+ ">=x11-proto/xcb-proto-1.11[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+
+python_check_deps() {
+ has_version --host-root ">=x11-proto/xcb-proto-1.11[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ $(use_enable xkb)
+ --enable-xinput
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libxcb/libxcb-9999.ebuild b/x11-libs/libxcb/libxcb-9999.ebuild
index e2df0077..fd627b43 100644
--- a/x11-libs/libxcb/libxcb-9999.ebuild
+++ b/x11-libs/libxcb/libxcb-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} )
PYTHON_REQ_USE=xml
XORG_DOC=doc
@@ -27,10 +27,10 @@ RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
DEPEND="${RDEPEND}
dev-libs/libxslt
$(python_gen_any_dep \
- ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+ ">=x11-proto/xcb-proto-1.11[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
python_check_deps() {
- has_version --host-root ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
+ has_version --host-root ">=x11-proto/xcb-proto-1.11[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
}
pkg_setup() {