summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-17 19:01:42 +0200
committerMichał Górny <mgorny@gentoo.org>2014-06-17 19:12:59 +0200
commit736dc19c612ff4180597ab3c581283c83d78ee33 (patch)
tree641d433fa17d12ce256519d135d180d39f9d38bd /x11-libs
parentmedia-libs/mesa: enable dri3 by default (diff)
downloadx11-736dc19c612ff4180597ab3c581283c83d78ee33.tar.gz
x11-736dc19c612ff4180597ab3c581283c83d78ee33.tar.bz2
x11-736dc19c612ff4180597ab3c581283c83d78ee33.zip
Add multilib support to all xcb-util* packages.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-9999.ebuild13
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-9999.ebuild9
-rw-r--r--x11-libs/xcb-util-keysyms/xcb-util-keysyms-9999.ebuild7
-rw-r--r--x11-libs/xcb-util-renderutil/xcb-util-renderutil-9999.ebuild7
-rw-r--r--x11-libs/xcb-util-wm/xcb-util-wm-9999.ebuild7
-rw-r--r--x11-libs/xcb-util/xcb-util-9999.ebuild15
6 files changed, 32 insertions, 26 deletions
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-9999.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-9999.ebuild
index aa9fd3e3..367bcc0d 100644
--- a/x11-libs/xcb-util-cursor/xcb-util-cursor-9999.ebuild
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
@@ -17,17 +18,17 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/xcb-util-${PV}
- x11-proto/xcb-proto
- x11-proto/xproto"
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xcb-proto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
-pkg_setup() {
+src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_with doc doxygen)
)
- xorg-2_pkg_setup
+ xorg-2_src_configure
}
diff --git a/x11-libs/xcb-util-image/xcb-util-image-9999.ebuild b/x11-libs/xcb-util-image/xcb-util-image-9999.ebuild
index 1906b686..0b7483d8 100644
--- a/x11-libs/xcb-util-image/xcb-util-image-9999.ebuild
+++ b/x11-libs/xcb-util-image/xcb-util-image-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
@@ -17,15 +18,15 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/xcb-util-${PV}
- x11-proto/xproto"
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_with doc doxygen)
)
xorg-2_src_configure
-} \ No newline at end of file
+}
diff --git a/x11-libs/xcb-util-keysyms/xcb-util-keysyms-9999.ebuild b/x11-libs/xcb-util-keysyms/xcb-util-keysyms-9999.ebuild
index 5050d056..2f999a2b 100644
--- a/x11-libs/xcb-util-keysyms/xcb-util-keysyms-9999.ebuild
+++ b/x11-libs/xcb-util-keysyms/xcb-util-keysyms-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-keysyms"
@@ -17,11 +18,11 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/xcb-util-${PV}
- x11-proto/xproto"
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
src_configure() {
XORG_CONFIGURE_OPTIONS=(
diff --git a/x11-libs/xcb-util-renderutil/xcb-util-renderutil-9999.ebuild b/x11-libs/xcb-util-renderutil/xcb-util-renderutil-9999.ebuild
index 75aedfb5..d2b97b1e 100644
--- a/x11-libs/xcb-util-renderutil/xcb-util-renderutil-9999.ebuild
+++ b/x11-libs/xcb-util-renderutil/xcb-util-renderutil-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-renderutil"
@@ -17,11 +18,11 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/xcb-util-${PV}
- x11-proto/xproto"
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
src_configure() {
XORG_CONFIGURE_OPTIONS=(
diff --git a/x11-libs/xcb-util-wm/xcb-util-wm-9999.ebuild b/x11-libs/xcb-util-wm/xcb-util-wm-9999.ebuild
index 0f59d53a..874344dd 100644
--- a/x11-libs/xcb-util-wm/xcb-util-wm-9999.ebuild
+++ b/x11-libs/xcb-util-wm/xcb-util-wm-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-wm"
@@ -17,11 +18,11 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/xcb-util-${PV}
- x11-proto/xproto"
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
src_configure() {
XORG_CONFIGURE_OPTIONS=(
diff --git a/x11-libs/xcb-util/xcb-util-9999.ebuild b/x11-libs/xcb-util/xcb-util-9999.ebuild
index 269138fb..0b769852 100644
--- a/x11-libs/xcb-util/xcb-util-9999.ebuild
+++ b/x11-libs/xcb-util/xcb-util-9999.ebuild
@@ -7,6 +7,7 @@ EAPI=5
XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
XORG_DOC=doc
+XORG_MULTILIB=yes
inherit xorg-2
EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util"
@@ -17,17 +18,17 @@ HOMEPAGE="http://xcb.freedesktop.org/"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"
-RDEPEND=">=x11-libs/libxcb-1.7
- x11-proto/xproto"
+RDEPEND=">=x11-libs/libxcb-1.7[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
- test? ( >=dev-libs/check-0.9.4 )"
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
PDEPEND="
- >=x11-libs/xcb-util-image-${PV}
- >=x11-libs/xcb-util-keysyms-${PV}
- >=x11-libs/xcb-util-renderutil-${PV}
- >=x11-libs/xcb-util-wm-${PV}
+ >=x11-libs/xcb-util-image-${PV}[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-keysyms-${PV}[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-${PV}[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-wm-${PV}[${MULTILIB_USEDEP}]
"
src_configure() {