summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2014-01-01 20:59:15 +0100
committerDavid Heidelberger <david.heidelberger@ixit.cz>2014-01-01 20:59:15 +0100
commit7b3d5ee13ce0147f1ed3cec8d8d629572f033869 (patch)
tree85afbfa48b8864227a2cd2cb72cfa0f8918d86a8 /x11-libs
parentx11-drivers/xf86-video-intel: fix build with xserver >= 1.14.99.2, fdo bug #7... (diff)
downloadx11-7b3d5ee13ce0147f1ed3cec8d8d629572f033869.tar.gz
x11-7b3d5ee13ce0147f1ed3cec8d8d629572f033869.tar.bz2
x11-7b3d5ee13ce0147f1ed3cec8d8d629572f033869.zip
x11-libs/libxkbcommon: migrate to multilib, git-r3, bump 0.3.1-r1, fix git url
Package-Manager: portage-2.2.7
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.3.1-r1.ebuild35
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-9999.ebuild20
3 files changed, 50 insertions, 6 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
new file mode 100644
index 00000000..a9856709
--- /dev/null
+++ b/x11-libs/libxkbcommon/Manifest
@@ -0,0 +1 @@
+DIST libxkbcommon-0.3.1.tar.xz 605756 SHA256 9c973581bba0c883a301fa6474d9c3e4f3a06c34e4ae4f1f4e113692cb18b38e SHA512 d5682f3663560d54bd3227ca0fdf52e651f2a14af46f49b4e7a5df2dc2e52748748f42c6334d6fd7328be72bd0c7e673e9783aa91d65a55a71266236f8b6a504 WHIRLPOOL f6472fa24c16c6f263e2ace807e4b2c7d4442d82e8d76ec047d4b9c312eaf889be26518fe3ffbd343610a5d966cf6b5df95cc47120ea60811cea4b687cc831ed
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.3.1-r1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.3.1-r1.ebuild
new file mode 100644
index 00000000..b3b97042
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+ KEYWORDS=""
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+
+IUSE="doc"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.5[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb" $(use_with doc doxygen)
+)
diff --git a/x11-libs/libxkbcommon/libxkbcommon-9999.ebuild b/x11-libs/libxkbcommon/libxkbcommon-9999.ebuild
index 6624208a..b3b97042 100644
--- a/x11-libs/libxkbcommon/libxkbcommon-9999.ebuild
+++ b/x11-libs/libxkbcommon/libxkbcommon-9999.ebuild
@@ -1,25 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-XORG_DOC="doc"
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
-if [[ ${PV} = 9999* ]]; then
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+ KEYWORDS=""
else
+ XORG_BASE_INDIVIDUAL_URI=""
SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
fi
inherit xorg-2 ${GIT_ECLASS}
DESCRIPTION="X.Org xkbcommon library"
-KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="doc"
DEPEND="sys-devel/bison
sys-devel/flex
- x11-proto/xproto
- >=x11-proto/kbproto-1.0.5"
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.5[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
RDEPEND=""
XORG_CONFIGURE_OPTIONS=(