summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2013-12-07 23:44:40 +0100
committerDavid Heidelberger <david.heidelberger@ixit.cz>2013-12-07 23:44:40 +0100
commitdde3f202bdccdc11a110d88af67b074ff8fb2a6b (patch)
tree2df510c313a7870228b80e94fd96393bed48a737 /x11-libs
parentradeontop: version bump, fix deps, add USE nls, respect CC, do not strip by d... (diff)
downloadx11-dde3f202bdccdc11a110d88af67b074ff8fb2a6b.tar.gz
x11-dde3f202bdccdc11a110d88af67b074ff8fb2a6b.tar.bz2
x11-dde3f202bdccdc11a110d88af67b074ff8fb2a6b.zip
x11-libs/libXft: fixed compilation 2.3.1-r1 with freetype 2.5.1
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXft/Manifest1
-rw-r--r--x11-libs/libXft/files/libXft-2.3.1-compile_fix.patch17
-rw-r--r--x11-libs/libXft/libXft-2.3.1-r1.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/libXft/Manifest b/x11-libs/libXft/Manifest
new file mode 100644
index 00000000..c69c5208
--- /dev/null
+++ b/x11-libs/libXft/Manifest
@@ -0,0 +1 @@
+DIST libXft-2.3.1.tar.bz2 311556 SHA256 7fce32b92dcb7b2869bed567af2abc7bbad0d5d6fcf471b8a3e137964a31bbbd SHA512 737d6ab892daf829da8b2fed954b31b2657d29033f35e806599cd67c6e044ab94b0f035804a1c4c9e3e0cbdc74a117cd274128a57f4b2cf81383561d62eb9f1f WHIRLPOOL ecd372614afc4fba05598e51c051f0a011c5ccaabc41e9e585b67180099cd9f7c6d68904adbe5ccf44f79133e21495daa6cd46675ca7556e7d7ab0dac1ee432a
diff --git a/x11-libs/libXft/files/libXft-2.3.1-compile_fix.patch b/x11-libs/libXft/files/libXft-2.3.1-compile_fix.patch
new file mode 100644
index 00000000..4fc944aa
--- /dev/null
+++ b/x11-libs/libXft/files/libXft-2.3.1-compile_fix.patch
@@ -0,0 +1,17 @@
+--- src/xftglyphs.c.orig 2012-06-02 11:36:35.000000000 -0500
++++ src/xftglyphs.c 2013-11-28 01:39:49.000000000 -0600
+@@ -21,10 +21,10 @@
+ */
+
+ #include "xftint.h"
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftlcdfil.h>
+-
+-#include <freetype/ftsynth.h>
++#include <ft2build.h>
++#include FT_OUTLINE_H
++#include FT_LCD_FILTER_H
++#include FT_SYNTHESIS_H
+
+ /*
+ * Validate the memory info for a font
diff --git a/x11-libs/libXft/libXft-2.3.1-r1.ebuild b/x11-libs/libXft/libXft-2.3.1-r1.ebuild
new file mode 100644
index 00000000..423d9d56
--- /dev/null
+++ b/x11-libs/libXft/libXft-2.3.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="X.Org Xft library"
+
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libXrender-0.8.2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ virtual/ttf-fonts"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-2.3.1-compile_fix.patch" )