summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-10-06 13:00:01 +0200
committerRémi Cardona <remi@gentoo.org>2009-10-06 13:00:01 +0200
commite0b70259b592c1e9a2f9198cd3d73d0b9c3dbffd (patch)
treebda034763edad59f63164e06e425fb8f462c44dd /x11-misc
parentadd the pre-commit hook script (diff)
downloadx11-e0b70259b592c1e9a2f9198cd3d73d0b9c3dbffd.tar.gz
x11-e0b70259b592c1e9a2f9198cd3d73d0b9c3dbffd.tar.bz2
x11-e0b70259b592c1e9a2f9198cd3d73d0b9c3dbffd.zip
x11-misc/xkeyboard-config: make a single ebuild for tarballs and git
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xkeyboard-config/Manifest2
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild51
2 files changed, 23 insertions, 30 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 954b2acf..691fd57f 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1 @@
-EBUILD xkeyboard-config-9999.ebuild 1581 RMD160 f054aeb16f9980e3cf1cc49548ab90e64d02dca1 SHA1 e09da6e460831777b11e2a124feace5eb9ce2314 SHA256 e262bfdca4a265523c36d6d368670b6bfe159c3a7119e5378f03220118e4a9ce
+EBUILD xkeyboard-config-9999.ebuild 1240 RMD160 26ae1646e5221585d2e27033b786f65e2b102065 SHA1 984c733b9addce0141b987dde82fbb1a6c5c6937 SHA256 43b8bee3f4ab2317f7d2ad25ffe946e5a0b2982dfc8f35f06d94d8a3d3aaec1d
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
index b1f47f56..becb6675 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
@@ -1,57 +1,50 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild,v 1.1 2009/10/06 10:47:02 remi Exp $
-inherit git autotools
+EAPI="2"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+else
+ SRC_URI="http://xlibs.freedesktop.org/xkbdesc/${P}.tar.bz2"
+fi
+
+inherit ${GIT_ECLASS} autotools
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
DESCRIPTION="X keyboard configuration database"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
-SRC_URI=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
LICENSE="MIT"
SLOT="0"
-RDEPEND="x11-apps/xkbcomp
- !x11-misc/xkbdata"
+RDEPEND="x11-apps/xkbcomp"
DEPEND="${RDEPEND}
sys-devel/gettext
dev-perl/XML-Parser"
-pkg_setup() {
- # (#130590) The old XKB directory can screw stuff up
- local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
- if [[ -d ${DIR} ]] ; then
- eerror "Directory ${DIR} should be"
- eerror "manually deleted/renamed/relocated before installing!"
- die "Manually remove ${DIR}"
- fi
-
- # The old xkbdata 'pc' directory can screw stuff up, because portage won't
- # let us overwrite a directory with a file
- local PC="${ROOT}usr/share/X11/xkb/symbols/pc"
- if [[ -d ${PC} ]] ; then
- eerror "Directory ${PC} should be"
- eerror "manually deleted/renamed/relocated before installing!"
- die "Manually remove ${PC}"
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ intltoolize
+ eautoreconf
fi
}
-src_compile() {
- intltoolize
- eautoreconf
+src_configure() {
econf \
--with-xkb-base=/usr/share/X11/xkb \
--enable-compat-rules \
--disable-xkbcomp-symlink \
--with-xkb-rules-symlink=xorg \
|| die "configure failed"
-
- emake || die "make failed"
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "install failed"
echo "CONFIG_PROTECT=\"/usr/share/X11/xkb\"" > "${T}"/10xkeyboard-config
doenvd "${T}"/10xkeyboard-config
}