summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesper Karlsson <zarper@gmail.com>2009-09-09 09:40:13 +0200
committerChristoph Mende <angelos@gentoo.org>2009-09-09 09:40:13 +0200
commit27402632b90796eae4990a388c229322dfe2bf74 (patch)
treeeeee07f5866d10136d957644f76f0c9e85522f3f /xfce-base/exo
parentRename xfce4 to xfce4-meta (diff)
downloadxfce-27402632b90796eae4990a388c229322dfe2bf74.tar.gz
xfce-27402632b90796eae4990a388c229322dfe2bf74.tar.bz2
xfce-27402632b90796eae4990a388c229322dfe2bf74.zip
Actually add files that were renamed not just delete them.
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest2
-rw-r--r--xfce-base/exo/exo-9999.ebuild45
-rw-r--r--xfce-base/exo/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
new file mode 100644
index 0000000..8354784
--- /dev/null
+++ b/xfce-base/exo/Manifest
@@ -0,0 +1,2 @@
+EBUILD exo-9999.ebuild 1068 RMD160 0858df41dd0f81587bebe1257733ab60da33b484 SHA1 8394ae2e302dd89b0127817b9a9cedbc75ecaee3 SHA256 3186ee18873f4bc8545e58401d86dcc321d1a52c5ecf9875afe48d33219147e4
+MISC metadata.xml 157 RMD160 d7470fe88d1b96f3a7f1ef26fb7dc646b4a1b907 SHA1 7eae91f2588bdae8667d37a98fb3090d539eeca1 SHA256 44350daa7594842894d676413708d8ea77ccb0017bed24711af5b256281f5e61
diff --git a/xfce-base/exo/exo-9999.ebuild b/xfce-base/exo/exo-9999.ebuild
new file mode 100644
index 0000000..439bc14
--- /dev/null
+++ b/xfce-base/exo/exo-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+MY_PN="lib${PN}"
+inherit xfce4 python
+
+xfce4_core
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc hal libnotify python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ libnotify? ( x11-libs/libnotify )
+ hal? ( sys-apps/hal )
+ python? ( dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+WANT_GTKDOCIZE="yes"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable hal)
+ $(use_enable libnotify notifications) $(use_enable python)"
+}
+
+pkg_postinst() {
+ xfce4_pkg_postinst
+ python_mod_optimize /usr/lib*/python*/site-packages
+}
+
+pkg_postrm() {
+ xfce4_pkg_postrm
+ python_mod_cleanup /usr/lib*/python*/site-packages
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
diff --git a/xfce-base/exo/metadata.xml b/xfce-base/exo/metadata.xml
new file mode 100644
index 0000000..826e2ca
--- /dev/null
+++ b/xfce-base/exo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>xfce</herd>
+</pkgmetadata>