summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-02-22 20:56:50 +0100
committerChristoph Mende <angelos@gentoo.org>2011-02-22 20:56:50 +0100
commit6e62429431018836e96c8ab833f984dd2df79f94 (patch)
tree429ffa69bf15dd43f8acc71f2f2791211475f4ee /xfce-base/exo
parentRemoved xfce4-meta (diff)
downloadxfce-6e62429431018836e96c8ab833f984dd2df79f94.tar.gz
xfce-6e62429431018836e96c8ab833f984dd2df79f94.tar.bz2
xfce-6e62429431018836e96c8ab833f984dd2df79f94.zip
New eclass: xfconf-live
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest2
-rw-r--r--xfce-base/exo/exo-9999.ebuild23
2 files changed, 13 insertions, 12 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 6133a26..d859d96 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,2 @@
-EBUILD exo-9999.ebuild 1381 RMD160 8e9453d1c389257b86d63475dfa741c716b3dde0 SHA1 eb9a00448cc97da0c1a97ff2c1b49fa994185ba5 SHA256 ffb7d347db2f41253022fa1013de99b61e361f53ab6c0e75cddf8883a110a9a3
+EBUILD exo-9999.ebuild 1415 RMD160 2c7e258615195137e91869920f7b5bc9a9587eae SHA1 37bdb0ee937ba4ed25ee710a8cdb62e796a354ea SHA256 9fca70c49c3c76cac9937c2ba305c7ca9681d241f40d5b16facf410b79665d37
MISC metadata.xml 157 RMD160 d7470fe88d1b96f3a7f1ef26fb7dc646b4a1b907 SHA1 7eae91f2588bdae8667d37a98fb3090d539eeca1 SHA256 44350daa7594842894d676413708d8ea77ccb0017bed24711af5b256281f5e61
diff --git a/xfce-base/exo/exo-9999.ebuild b/xfce-base/exo/exo-9999.ebuild
index 75c1d28..f4d666c 100644
--- a/xfce-base/exo/exo-9999.ebuild
+++ b/xfce-base/exo/exo-9999.ebuild
@@ -6,9 +6,9 @@ EAPI=3
PYTHON_DEPEND="python? 2"
-inherit xfce4 python
+GTKDOCIZE="yes"
-xfce4_core
+inherit python xfconf-live
DESCRIPTION="Extensions, widgets and framework library with session management support"
HOMEPAGE="http://www.xfce.org/projects/exo/"
@@ -25,23 +25,24 @@ RDEPEND=">=dev-lang/perl-5.6
>=xfce-base/libxfce4util-4.8
python? ( >=dev-python/pygtk-2.4 )"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
dev-util/intltool
- dev-util/gtk-doc
sys-devel/gettext"
-WANT_GTKDOCIZE="yes"
-
pkg_setup() {
if use python; then
python_set_active_version 2
python_pkg_setup
fi
- XFCE_CONFIG+=" --disable-dependency-tracking
- --docdir=${EPREFIX}/usr/share/doc/${PF}
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
--disable-static
$(use_enable python)
- --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
DOCS="AUTHORS HACKING NEWS README THANKS TODO"
}
@@ -50,15 +51,15 @@ src_prepare() {
rm -f py-compile
ln -s $(type -P true) py-compile
- xfce4_src_prepare
+ xfconf-live_src_prepare
}
pkg_postinst() {
- xfce4_pkg_postinst
+ xfconf-live_pkg_postinst
use python && python_mod_optimize exo-0.6 pyexo.py
}
pkg_postrm() {
- xfce4_pkg_postrm
+ xfconf-live_pkg_postrm
use python && python_mod_cleanup exo-0.6 pyexo.py
}