summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-23 20:10:25 +0200
committerChristoph Mende <angelos@gentoo.org>2010-05-23 20:10:25 +0200
commit942504be8c2b5a90dd0b25d3549aafcb784cb56f (patch)
treeb288a8c3d123794aba0fc50fbe2ad86d35900597 /xfce-base/exo
parentthunar-vfs: Moved to xfce-extra and synced with main tree (diff)
downloadxfce-942504be8c2b5a90dd0b25d3549aafcb784cb56f.tar.gz
xfce-942504be8c2b5a90dd0b25d3549aafcb784cb56f.tar.bz2
xfce-942504be8c2b5a90dd0b25d3549aafcb784cb56f.zip
exo: Synced with main tree
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest2
-rw-r--r--xfce-base/exo/exo-9999.ebuild48
2 files changed, 32 insertions, 18 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index c6b1051..10df107 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,2 @@
-EBUILD exo-9999.ebuild 1042 RMD160 592997d7797e5e371e0942d610644ba4f58ab4f1 SHA1 2316c93add3e841c92fe42885aca7386e706d0c9 SHA256 68819405872aa176ec0a2c1ddff7f7b784e06b46a6882ea4cf0658706bffb9c2
+EBUILD exo-9999.ebuild 1395 RMD160 901b5a4ea3f33bbb800414b5d8fde508e245942f SHA1 10409e38f15226a527a5c154172ed612609855ad SHA256 8ed65cbac3d64b1f52b36bce2d9cec7ec1b7a047e0d12416d3d0b7df4ff50ff7
MISC metadata.xml 157 RMD160 d7470fe88d1b96f3a7f1ef26fb7dc646b4a1b907 SHA1 7eae91f2588bdae8667d37a98fb3090d539eeca1 SHA256 44350daa7594842894d676413708d8ea77ccb0017bed24711af5b256281f5e61
diff --git a/xfce-base/exo/exo-9999.ebuild b/xfce-base/exo/exo-9999.ebuild
index f842b1d..c2af238 100644
--- a/xfce-base/exo/exo-9999.ebuild
+++ b/xfce-base/exo/exo-9999.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=1
-
+EAPI=3
inherit xfce4 python
xfce4_core
DESCRIPTION="Extensions, widgets and framework library with session management support"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc hal libnotify python"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug hal libnotify python"
RDEPEND=">=dev-lang/perl-5.6
dev-perl/URI
- >=dev-libs/glib-2.6:2
- >=x11-libs/gtk+-2.6:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- libnotify? ( x11-libs/libnotify )
- hal? ( sys-apps/hal )
- python? ( dev-python/pygtk )"
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.4.2
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ hal? ( >=sys-apps/hal-0.5.7 )
+ python? ( >=dev-python/pygtk-2.4 )"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/gtk-doc"
@@ -27,18 +26,33 @@ DEPEND="${RDEPEND}
WANT_GTKDOCIZE="yes"
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable hal)
- $(use_enable libnotify notifications) $(use_enable python)"
+ XFCE_CONFIG+=" --disable-dependency-tracking
+ --disable-static
+ $(use_enable libnotify notifications)
+ $(use_enable hal)
+ $(use_enable python)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ if [[ ${CHOST} == *-interix* ]] ; then
+ # configure detects getmntent, which is false!
+ export ac_cv_func_getmntent=no
+ fi
+
+ xfce4_src_prepare
}
pkg_postinst() {
xfce4_pkg_postinst
- python_mod_optimize /usr/lib*/python*/site-packages
+ python_mod_optimize exo-0.5 pyexo.py
}
pkg_postrm() {
xfce4_pkg_postrm
- python_mod_cleanup /usr/lib*/python*/site-packages
+ python_mod_cleanup exo-0.5 pyexo.py
}
-
-DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"