summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-30 20:09:35 +0200
committerChristoph Mende <angelos@gentoo.org>2010-05-30 20:09:35 +0200
commit12fb863eb4d9a79d34b097b2eaa264be35d161b3 (patch)
treedec353191055f52bd82958994e8a264363732e08 /xfce-base/xfdesktop
parentcleanup (diff)
downloadxfce-12fb863eb4d9a79d34b097b2eaa264be35d161b3.tar.gz
xfce-12fb863eb4d9a79d34b097b2eaa264be35d161b3.tar.bz2
xfce-12fb863eb4d9a79d34b097b2eaa264be35d161b3.zip
Overhaul
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest3
-rw-r--r--xfce-base/xfdesktop/xfdesktop-9999.ebuild79
2 files changed, 48 insertions, 34 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 7051730..be5e869 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
-EBUILD xfdesktop-9999.ebuild 1802 RMD160 7f2858322f423e73c24760d80c3b96913e1efa9f SHA1 02ddef07f175dddcf8f70b545ac95448daf3d33d SHA256 285ce36ef5a363c325ceb906de085e195db607662126d447f39ddb2e5ddf6ef9
+DIST gentoo-minimal-1280x1024.jpg 103489 RMD160 9d736c236c29c39836910337c6b9b62e0d217c08 SHA1 0ef26494879e6e4f4e66f9111ebfc1080423217b SHA256 6134b6eea65e6c8e996cfaab07d30050d66207a518d589bc9115f8342255c57b
+EBUILD xfdesktop-9999.ebuild 2157 RMD160 22e46ab37f413ce6e5bf288b681075b70b39f841 SHA1 7d05be8ac16d18499ad84a0aa1af3b9f003ea97a SHA256 662895d8d53df7d46131aff65d33ac36a055121f347c219b3123bc38f29941ba
MISC metadata.xml 351 RMD160 4401cf2e2c9cc9f166bdff78a1e15612e784ad1d SHA1 dc6b0946171dda265a9b13871899a9a8e071f6db SHA256 f2a98defe794e66d32ba0f9041a7b0afb7209345974f114ee2b8454dbe4bc6e9
diff --git a/xfce-base/xfdesktop/xfdesktop-9999.ebuild b/xfce-base/xfdesktop/xfdesktop-9999.ebuild
index ba8af3c..dcd0698 100644
--- a/xfce-base/xfdesktop/xfdesktop-9999.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-9999.ebuild
@@ -1,58 +1,73 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=1
-
-inherit eutils xfce4
+EAPI=2
+inherit xfce4
xfce4_core
-DESCRIPTION="Desktop manager"
+DESCRIPTION="Desktop manager for Xfce4"
HOMEPAGE="http://www.xfce.org/projects/xfdesktop"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc +file-icons +menu-plugin"
+SRC_URI="branding? ( http://www.gentoo.org/images/backgrounds/gentoo-minimal-1280x1024.jpg )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+branding debug doc thunar"
LINGUAS="be ca cs da de el es et eu fi fr he hu it ja ko nb_NO nl pa pl pt_BR ro ru sk sv tr uk vi zh_CN zh_TW"
-RDEPEND="x11-libs/libX11
+for X in ${LINGUAS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="gnome-base/libglade
+ x11-libs/libX11
x11-libs/libSM
>=x11-libs/libwnck-2.12
- >=dev-libs/glib-2.10:2
- >=x11-libs/gtk+-2.10:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfce4ui-${XFCE_VERSION}
- >=xfce-base/libxfce4menu-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
- file-icons? ( xfce-extra/thunar-vfs
- >=xfce-base/exo-0.3.100 dev-libs/dbus-glib )
- menu-plugin? ( >=xfce-base/xfce4-panel-${XFCE_VERSION} )"
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/libxfce4menu-4.6
+ >=xfce-base/xfconf-4.6
+ branding? ( >=x11-libs/gtk+-2.10:2[jpeg] )
+ thunar? ( >=xfce-base/thunar-1
+ >=xfce-base/exo-0.3.100
+ dev-libs/dbus-glib )"
DEPEND="${RDEPEND}
dev-util/intltool
doc? ( dev-libs/libxslt )"
-for X in ${LINGUAS}; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-XFCE_LOCALIZED_CONFIGS="/etc/xdg/xfce4/desktop/xfce-registered-categories.xml
- /etc/xdg/xfce4/desktop/menu.xml"
-
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable doc xsltproc) $(use_enable menu-plugin panel-plugin)"
+ XFCE_LOCALIZED_CONFIGS="/etc/xdg/xfce4/desktop/menu.xml
+ /etc/xdg/xfce4/desktop/xfce-registered-categories.xml"
+ # TODO: fix USE=thunar
+ XFCE_CONFIG+=" --disable-dependency-tracking
+ --disable-static
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable thunar exo)
+ $(use_enable thunar desktop-menu)
+ $(use_enable doc xsltproc)"
+ DOCS="AUTHORS ChangeLog NEWS TODO README"
+}
- if use file-icons; then
- XFCE_CONFIG+=" --enable-thunarx --enable-file-icons --enable-exo
- --enable-desktop-icons"
- else
- XFCE_CONFIG+=" --disable-thunarx --disable-file-icons --disable-exo
- --disable-desktop-icons"
+src_prepare() {
+ if use branding; then
+ sed -i -e "s:xfce-stripes.png:gentoo-minimal-1280x1024.jpg:" \
+ common/xfdesktop-common.h || die "sed failed"
fi
+ xfce4_src_prepare
}
src_install() {
xfce4_src_install
+ if use branding; then
+ insinto /usr/share/xfce4/backdrops
+ doins "${DISTDIR}"/gentoo-minimal-1280x1024.jpg || die "doins failed"
+ fi
+
local config lang
for config in ${XFCE_LOCALIZED_CONFIGS}; do
for lang in ${LINGUAS}; do
@@ -63,5 +78,3 @@ src_install() {
done
done
}
-
-DOCS="AUTHORS ChangeLog HACKING NEWS TODO README"