summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-05 08:26:57 +0200
committerChristoph Mende <angelos@gentoo.org>2011-07-05 08:26:57 +0200
commita4888028803c5b5729f8f345b8b29a14b03a0f93 (patch)
tree57508b90df11cc7f02514d26adc86161944ce65f /xfce-base
parentRemove package.mask (diff)
downloadxfce-a4888028803c5b5729f8f345b8b29a14b03a0f93.tar.gz
xfce-a4888028803c5b5729f8f345b8b29a14b03a0f93.tar.bz2
xfce-a4888028803c5b5729f8f345b8b29a14b03a0f93.zip
exo: Python bindings were moved to pyxfce
(Portage version: 2.2.0_alpha43/git/Linux x86_64, signed Manifest commit with key 84F20B43)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest18
-rw-r--r--xfce-base/exo/exo-9999.ebuild36
2 files changed, 10 insertions, 44 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index a490c31..efe0406 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,22 +1,12 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
-- -----BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA256
-
-EBUILD exo-9999.ebuild 1415 RMD160 ae25a3800326ad2c4f6ab90911a0f28bbb3100c6 SHA1 be6d63743d993ca0e6b184474bb21e3703c8c88f SHA256 7f10a108771702627513492bbf0b9985bd8cb8e9bf34de259249b07b58cb4359
+EBUILD exo-9999.ebuild 981 RMD160 6f8e22b23d62be27265b0d1b0c8148016c200fa4 SHA1 239d1c267396f57e13ab0d3e1d318ecdc318b5fa SHA256 8de52572e49ff806c87552176467d1a611d18ddd78ab9bbeacc5ec708f191519
MISC metadata.xml 159 RMD160 43722935bd7b4db7fe8db681054f2e53c4a5f7ce SHA1 15958ad72e234ba572c9534533c21532eb6bc0fd SHA256 900ea49b6703fce452e205b85226bf1f994725963e5840da501182e7487d0e63
-- -----BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.17 (GNU/Linux)
-
-iF4EAREIAAYFAk32W48ACgkQmWq1bYTyC0OwJgD/dzNe5EgdwfuxA4uyYp+HEdLT
-k+/tXMtUIONN1Ub5v2QBAI8PWsAZV7+kKM/bnCVTAbuJJqEp2VPIMDJ8C+Z8c/0t
-=JWuc
-- -----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
-iF4EAREIAAYFAk32XCIACgkQmWq1bYTyC0NqLQEAkxv5gIeryvYoivoGUxVxlD+v
-4uzs7P3J8sT5jxyv31AA/0Y2zwgg3BZ0KjzAySjtmbf0Aoo/PLnng9jUL3MI3eBo
-=o2ps
+iF4EAREIAAYFAk4SrrEACgkQmWq1bYTyC0P1kAD+MfTDQl2ESIQv7gaPNH08a9YN
+unvoYI8aTl0n6RJ3i5UBALLH3nEj4cvTRWhJ5PuNvddlZYbHxPphqU1VcOglJN0V
+=Ui7A
-----END PGP SIGNATURE-----
diff --git a/xfce-base/exo/exo-9999.ebuild b/xfce-base/exo/exo-9999.ebuild
index b8adddf..e69cc96 100644
--- a/xfce-base/exo/exo-9999.ebuild
+++ b/xfce-base/exo/exo-9999.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.2.ebuild,v 1.1 2011/06/10 18:38:28 angelos Exp $
-EAPI=3
-PYTHON_DEPEND="python? 2"
-inherit python xfconf
+EAPI=4
+inherit xfconf
DESCRIPTION="Extensions, widgets and framework library with session management support"
HOMEPAGE="http://www.xfce.org/projects/exo/"
@@ -12,30 +11,24 @@ HOMEPAGE="http://www.xfce.org/projects/exo/"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug python"
+IUSE="debug"
RDEPEND=">=dev-lang/perl-5.6
dev-perl/URI
>=dev-libs/glib-2.18:2
>=x11-libs/gtk+-2.14:2
- >=xfce-base/libxfce4util-4.8
- python? ( >=dev-python/pygtk-2.4 )"
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool
sys-devel/gettext"
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-
XFCONF=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
- --disable-dependency-tracking
--disable-static
- $(use_enable python)
$(xfconf_use_debug)
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
)
@@ -43,20 +36,3 @@ pkg_setup() {
DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
}
-
-src_prepare() {
- rm -f py-compile
- ln -s $(type -P true) py-compile
-
- xfconf_src_prepare
-}
-
-pkg_postinst() {
- xfconf_pkg_postinst
- use python && python_mod_optimize exo-0.6 pyexo.py
-}
-
-pkg_postrm() {
- xfconf_pkg_postrm
- use python && python_mod_cleanup exo-0.6 pyexo.py
-}