summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasili Bulkin <bulkin@letterboxes.org>2016-10-31 09:02:38 -0500
committerDoug Goldstein <cardoe@gentoo.org>2016-10-31 09:02:38 -0500
commit4f6cd6184c7dd680a1e74dda900b39b2fc03170a (patch)
treed2b9d4e9f469abfa6cf391c31150fc97dc79f95f
parentsys-kernel/gentoo-sources: Linux patch 4.8.6 (diff)
downloadgentoo-4f6cd6184c7dd680a1e74dda900b39b2fc03170a.tar.gz
gentoo-4f6cd6184c7dd680a1e74dda900b39b2fc03170a.tar.bz2
gentoo-4f6cd6184c7dd680a1e74dda900b39b2fc03170a.zip
dev-lang/rust: drop need for USE+multitarget on LLVM
Rust no longer needs USE=multitarget when building against the system LLVM. fixes bug #598144 Gentoo-Bug: 598144 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.12.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.12.1.ebuild b/dev-lang/rust/rust-1.12.1.ebuild
index 54e3fd4e6ece..253cd05e9b36 100644
--- a/dev-lang/rust/rust-1.12.1.ebuild
+++ b/dev-lang/rust/rust-1.12.1.ebuild
@@ -42,8 +42,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2:=[multitarget]
- <sys-devel/llvm-3.9.0:=[multitarget] )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2
+ <sys-devel/llvm-3.9.0 )
"
DEPEND="${RDEPEND}