summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-04-14 13:23:18 -0700
committerZac Medico <zmedico@gentoo.org>2024-04-14 13:23:31 -0700
commit05c7076cf6731a60b6778e5b30fb82020e2afa6b (patch)
treeea97ff9cdeae8113df0b595d6d3724daae1620ab /app-admin
parentapp-containers/containers-common: Make 0.57.0 require older containers-image (diff)
downloadgentoo-05c7076cf6731a60b6778e5b30fb82020e2afa6b.tar.gz
gentoo-05c7076cf6731a60b6778e5b30fb82020e2afa6b.tar.bz2
gentoo-05c7076cf6731a60b6778e5b30fb82020e2afa6b.zip
app-admin/consul: drop 1.15.10
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/Manifest1
-rw-r--r--app-admin/consul/consul-1.15.10.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 23c8480a9d1c..9532d6fa5036 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -1,4 +1,3 @@
-DIST consul-1.15.10-vendor.tar.gz 46702348 BLAKE2B a04d6f5a4d2f6f8885207f9f72537d4ea1a3adc5aab64873edf7f710984d3b25a602fb93cecc44ed82249280b51bbe1131701ab09f7ebb1b444c80e013fe271d SHA512 7aade3f90ee689ddca3058f12e7c9f2a691c4eba966993d770d8dc7b171cad54c3c8b6c3f52e03128a8d1b159dd66b6c8b284050c5475d77b51f9a22c4a6af8a
DIST consul-1.15.11-deps.tar.xz 9566892 BLAKE2B 9459a93d78d3e4b991d0cdcfac22603c628c8f9fdacd8d50524a4c826cca66a575f6cd0bdf5fa9033e32b50336c53192567610ed73386f89c3c4e810c1412144 SHA512 d3876433b4ad3e7a062e059ef250bcfba23ede0595d8491f4b39c73c427e28c677b9f6e41317cf853ab8b3b2ce25151a4adf1a13b13a6a73c6e16de7382d2d05
DIST consul-1.15.11.tar.gz 28951114 BLAKE2B 02378088d1bbc4313ec62d644b583c328bc9cc40ccc18516a1a14ae0d7f8d12007f1a5fa7c5e455ec2e782ba986ce60d37b92369b1f89f7dd69871702cd97b31 SHA512 1c5c8f9a3ad79aa34fd82a49e92ef5a21fb0470d60e3f3413901305121cbb677c75f72ffd5405554424b336d4e5ec426b7c35f458c04b1d5ab9350c2649cd688
DIST consul-1.15.3-vendor.tar.gz 43434721 BLAKE2B 7595c98cdecf67e9fb412d8fea1d790dc6b1c29f7bc427e1d0872045a05f8873dc6107f196cea04fe0a2f2553d4fbb1f8d501e5e107b2bea3ae841e5d94eda64 SHA512 b69e3a7c1ebb01c7a64f2c6167e63e8a530b81be9aad8b591d0a71f512f5157ba9a564b46f9effe52a5abd3ae61732e7af10c5ba002110f745eb3d94ebcec256
diff --git a/app-admin/consul/consul-1.15.10.ebuild b/app-admin/consul/consul-1.15.10.ebuild
deleted file mode 100644
index 7fbf1eb317a7..000000000000
--- a/app-admin/consul/consul-1.15.10.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-GIT_COMMIT="a8dca2405236750fc23fb31dac21507882d111f6"
-
-SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT="test"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-S=${WORKDIR}/${P}-vendor
-
-src_prepare() {
- default
- sed -e 's|^GIT_DATE=.*|GIT_DATE=2023-10-31T14:10:44Z|' -i GNUmakefile || die
-}
-
-src_compile() {
- if use x86; then
- #924629 pie breaks build on x86
- GOFLAGS=${GOFLAGS//-buildmode=pie}
- fi
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}