summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-14 23:43:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-14 23:44:36 +0000
commit8127dfca758f20a51a4906e1967ff50369a1017b (patch)
treea3575243cf40df3ead4875c8dc490c1896c0a2a4 /app-arch
parentdev-java/icedtea-bin: Version bump to 7.2.6.2 (diff)
parentapp-arch/lha: QA warnings are now gone for good. (diff)
downloadgentoo-8127dfca758f20a51a4906e1967ff50369a1017b.tar.gz
gentoo-8127dfca758f20a51a4906e1967ff50369a1017b.tar.bz2
gentoo-8127dfca758f20a51a4906e1967ff50369a1017b.zip
Merge remote-tracking branch 'github/pr/349'.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch11
-rw-r--r--app-arch/lha/lha-114i-r8.ebuild53
2 files changed, 64 insertions, 0 deletions
diff --git a/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch b/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch
new file mode 100644
index 000000000000..b57a1c9c6158
--- /dev/null
+++ b/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch
@@ -0,0 +1,11 @@
+--- src/getopt_long.c.orig 2013-12-18 16:05:59.789413528 -0600
++++ src/getopt_long.c 2013-12-18 16:06:01.200420472 -0600
+@@ -64,7 +64,7 @@
+
+ #ifndef USE_GNU
+ #include <stdio.h>
+-#include <getopt_long.h>
++#include "getopt_long.h"
+
+ char *optarg;
+ int optind;
diff --git a/app-arch/lha/lha-114i-r8.ebuild b/app-arch/lha/lha-114i-r8.ebuild
new file mode 100644
index 000000000000..301e798ecedc
--- /dev/null
+++ b/app-arch/lha/lha-114i-r8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+MY_P=${PN}-1.14i-ac20050924p1
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="http://lha.sourceforge.jp"
+SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-file-list-from-stdin.patch
+ "${FILESDIR}"/${P}-fix-getopt_long-declaration.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ sed -e '/^AM_C_PROTOTYPES/d' \
+ -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ -i configure.ac || die #423125, 467544
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DPROTOTYPES #423125
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ econf
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}"/usr/share/man/ja \
+ install
+
+ dodoc ChangeLog Hacking_of_LHa
+}