summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/dbench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/dbench')
-rw-r--r--app-benchmarks/dbench/Manifest1
-rw-r--r--app-benchmarks/dbench/dbench-4.0.ebuild42
-rw-r--r--app-benchmarks/dbench/metadata.xml9
3 files changed, 52 insertions, 0 deletions
diff --git a/app-benchmarks/dbench/Manifest b/app-benchmarks/dbench/Manifest
new file mode 100644
index 000000000000..39640a7d581b
--- /dev/null
+++ b/app-benchmarks/dbench/Manifest
@@ -0,0 +1 @@
+DIST dbench-4.0.tar.gz 2055359 SHA256 6001893f34e68a3cfeb5d424e1f2bfef005df96a22d86f35dc770c5bccf3aa8a SHA512 70c65c5b079edf745c267be753919c780153c9064dbda95c270b3c2c1d8c16e84fab4e743eb777436813678ecff13ec2b55d011e8acc4bd83e58f0dda7438e7f WHIRLPOOL f39d17ec5ec6e8618045337c408f7c7dc722a8c54c68872ca5a03c8affd35de1f6e6d5e842e90dcb889816fc7891f31b9217d2591ec2e90c056d92fdca90da89
diff --git a/app-benchmarks/dbench/dbench-4.0.ebuild b/app-benchmarks/dbench/dbench-4.0.ebuild
new file mode 100644
index 000000000000..a9c818f7f109
--- /dev/null
+++ b/app-benchmarks/dbench/dbench-4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Popular filesystem benchmark"
+SRC_URI="ftp://ftp.samba.org/pub/tridge/dbench/${P}.tar.gz"
+HOMEPAGE="http://samba.org/ftp/tridge/dbench/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="dev-libs/popt"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoheader
+ eautoconf
+ sed -i -e \
+ "s:\$(CC) -o:\$(CC) \$(LDFLAGS) -o:" \
+ Makefile.in || die
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin dbench tbench tbench_srv
+ dodoc README INSTALL
+ doman dbench.1
+ insinto /usr/share/dbench
+ doins client.txt
+}
+
+pkg_postinst() {
+ elog "You can find the client.txt file in ${ROOT}usr/share/dbench."
+}
diff --git a/app-benchmarks/dbench/metadata.xml b/app-benchmarks/dbench/metadata.xml
new file mode 100644
index 000000000000..ca0d72e3113b
--- /dev/null
+++ b/app-benchmarks/dbench/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>