summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-08-16 13:30:25 +0000
committerJoonas Niilola <juippis@gentoo.org>2019-08-17 18:49:43 +0300
commit7b272790754d30c31beb1d4ec8de5223c256752a (patch)
tree61022b67e0894fefea310bacf4d7d799b10aadee /app-benchmarks/sysbench
parentapp-benchmarks/sysbench: bump to 1.0.17 (diff)
downloadgentoo-7b272790754d30c31beb1d4ec8de5223c256752a.tar.gz
gentoo-7b272790754d30c31beb1d4ec8de5223c256752a.tar.bz2
gentoo-7b272790754d30c31beb1d4ec8de5223c256752a.zip
app-benchmarks/sysbench: sync live ebuild
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-benchmarks/sysbench')
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
index 6873945f546c..4787bb37870a 100644
--- a/app-benchmarks/sysbench/sysbench-9999.ebuild
+++ b/app-benchmarks/sysbench/sysbench-9999.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit git-r3
+inherit autotools git-r3 pax-utils
DESCRIPTION="System performance benchmark"
HOMEPAGE="https://github.com/akopytov/sysbench"
-
EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE="aio mysql postgres test"
+RESTRICT="!test? ( test )"
RDEPEND="aio? ( dev-libs/libaio )
mysql? ( virtual/libmysqlclient )
postgres? ( dev-db/postgresql:= )
dev-lang/luajit:="
DEPEND="${RDEPEND}
- app-editors/vim-core
dev-libs/concurrencykit
dev-libs/libxslt
sys-devel/libtool
@@ -33,17 +32,14 @@ src_prepare() {
# remove bundled libs
rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die
- ./autogen.sh || die
+ eautoreconf
}
src_configure() {
local myeconfargs=(
- $(use_enable aio aio)
- $(use_with mysql mysql)
+ $(use_enable aio)
+ $(use_with mysql)
$(use_with postgres pgsql)
- --without-attachsql
- --without-drizzle
- --without-oracle
--with-system-luajit
--with-system-ck
)
@@ -54,3 +50,9 @@ src_configure() {
src_test() {
emake check test
}
+
+src_install() {
+ default
+
+ pax-mark m "${ED}"/usr/bin/${PN}
+}