summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-14 23:11:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-15 00:20:48 +0200
commit33548133dade16fb468157a90dd9d8491dbc29b7 (patch)
tree2809ecde4a48deb2f0035af9853b5ae54fad8e05 /app-containers
parentapp-containers/earthly: drop old 0.8.6 (diff)
downloadgentoo-33548133dade16fb468157a90dd9d8491dbc29b7.tar.gz
gentoo-33548133dade16fb468157a90dd9d8491dbc29b7.tar.bz2
gentoo-33548133dade16fb468157a90dd9d8491dbc29b7.zip
app-containers/earthly: bump to 0.8.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.10.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 7aaa08262b67..2bdb0873f554 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,3 +1,5 @@
+DIST earthly-0.8.10-deps.tar.zst 180360414 BLAKE2B c734773657da1194f2708212aca3e8fa2ec7869350c47c5ee5b52c2931e56ddce9292c1670f7d8ce089a8f6597e4fa25b29b1e57304c248ab29f783e040691f1 SHA512 2745f08330403e4976fb970ba2e7bbac769b20111571c800e9e774a4486b9da816d91da8d83e2b4fcc53627184a7c054e9f66c182cba9af5a9b7d6e044ad9a19
+DIST earthly-0.8.10.tar.gz 8089062 BLAKE2B 0d3e29b84121d42995c8171a4e39815fb752d2aa36eb00efd0286a8cbd014d1b64db576f654104412433e5403812f1fa8bed2bbcfb981589fdab1fbc30e4dc1f SHA512 1449953fd705f3547f4da9eb53a674a6ef37d30a669b758a9abad5800decef650f57f3ec4436de191c8aff09d4c1b4b4bdaf5e591af1a06d568fdd18ab3670f9
DIST earthly-0.8.7-deps.tar.zst 180209748 BLAKE2B e4c5f4b856d0ed3a0c757128c144f6267fd763118de12a51877781e82ea15722420c871f5d66a4dd797cc67b85b7c7cd26a1d2e8f417bd5517f1109e376bbefc SHA512 b8dc56b302aca63837a87cfcced4d0387adaea5433b72eb7c7056dab8a486208d06fff39b4ecd753a30f27878b1497eb1892456876e7632ee2c44926747a12d6
DIST earthly-0.8.7.tar.gz 8062437 BLAKE2B 82796711c13cb7fd2bf957148ddd7ff31d14b9888b30a910682b956ecb8cd9c66539a71b558f92f972b54c566411257c769dadfe2e1d720d9a4e496292185d48 SHA512 c8bddfc2c4e5702abb5c119a022ab5cc875b460535fb5af4364ee7bd89e950768f71fe1ccf1860d0826d8934b283745ca22abae147852a7b779081373b40be4f
DIST earthly-0.8.8-deps.tar.zst 180214607 BLAKE2B f407dcc4cb8daee7ac53433af830b6c872b0c9e1e05004b2bc4c8706eb98b65e457f7bea2b221e6c4cf4dfe8bb218a5ca60e85beb1f7839cb0ffaadaf8110ad3 SHA512 6a9d0eb7a69b36cca2f79d3f92e21f9f97d858451308f7151e4810c479105b7dad3fe2ad1b8a90a6ca9f0c7d3d06a8f89cd3eab4fde54e10fae2e3ea98fbb7bb
diff --git a/app-containers/earthly/earthly-0.8.10.ebuild b/app-containers/earthly/earthly-0.8.10.ebuild
new file mode 100644
index 000000000000..3764c02e729f
--- /dev/null
+++ b/app-containers/earthly/earthly-0.8.10.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.8.10 ]] ; then
+ COMMIT_SHA=9050356a89d53c96ff94b6a46107274426353441
+else
+ die 'Could not detect "COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module unpacker
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.zst
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpacker "${P}-deps.tar.zst"
+
+ go-module_src_unpack
+}
+
+src_compile() {
+ local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local -r go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a -r go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o ./bin/
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}