summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-04-28 17:57:14 +1100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-04-28 17:58:00 +1100
commitb1bd5d199e46738f80666d4171726fc0941566b7 (patch)
tree3308b3dd39079750170dac2b1c537fd47541f7ef /app-containers
parentx11-plugins/wmcalendar: update EAPI 7 -> 8 (diff)
downloadgentoo-b1bd5d199e46738f80666d4171726fc0941566b7.tar.gz
gentoo-b1bd5d199e46738f80666d4171726fc0941566b7.tar.bz2
gentoo-b1bd5d199e46738f80666d4171726fc0941566b7.zip
app-containers/docker: Fix automagic systemd dependency
This broke the binary packages for half our users. Closes: https://bugs.gentoo.org/914076 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker/docker-24.0.5-r1.ebuild (renamed from app-containers/docker/docker-24.0.5.ebuild)8
-rw-r--r--app-containers/docker/docker-24.0.7-r1.ebuild (renamed from app-containers/docker/docker-24.0.7.ebuild)8
-rw-r--r--app-containers/docker/docker-26.1.0-r1.ebuild (renamed from app-containers/docker/docker-26.1.0.ebuild)3
-rw-r--r--app-containers/docker/files/docker-24.0.5-automagic-systemd.patch13
-rw-r--r--app-containers/docker/files/docker-26.1.0-automagic-systemd.patch13
5 files changed, 41 insertions, 4 deletions
diff --git a/app-containers/docker/docker-24.0.5.ebuild b/app-containers/docker/docker-24.0.5-r1.ebuild
index ac578996d43f..2421fd8dd3eb 100644
--- a/app-containers/docker/docker-24.0.5.ebuild
+++ b/app-containers/docker/docker-24.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv ~x86"
-IUSE="apparmor btrfs +container-init device-mapper overlay seccomp selinux"
+IUSE="apparmor btrfs +container-init device-mapper overlay seccomp selinux systemd"
DEPEND="
acct-group/docker
@@ -23,6 +23,7 @@ DEPEND="
btrfs? ( >=sys-fs/btrfs-progs-3.16.1 )
device-mapper? ( >=sys-fs/lvm2-2.02.89[thin] )
seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+ systemd? ( sys-apps/systemd )
"
# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#runtime-dependencies
@@ -54,6 +55,7 @@ S="${WORKDIR}/${P}/src/${EGO_PN}"
# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
PATCHES=(
"${FILESDIR}/0001-Openrc-Depend-on-containerd-init-script.patch"
+ "${FILESDIR}/docker-24.0.5-automagic-systemd.patch"
)
pkg_setup() {
@@ -263,6 +265,8 @@ src_compile() {
fi
done
+ export SYSTEMD=$(usex systemd 1 0)
+
# build binaries
./hack/make.sh dynbinary || die 'dynbinary failed'
}
diff --git a/app-containers/docker/docker-24.0.7.ebuild b/app-containers/docker/docker-24.0.7-r1.ebuild
index 14dddd2aafd9..ad913c3d0c3b 100644
--- a/app-containers/docker/docker-24.0.7.ebuild
+++ b/app-containers/docker/docker-24.0.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apparmor btrfs +container-init device-mapper overlay seccomp selinux"
+IUSE="apparmor btrfs +container-init device-mapper overlay seccomp selinux systemd"
DEPEND="
acct-group/docker
@@ -23,6 +23,7 @@ DEPEND="
btrfs? ( >=sys-fs/btrfs-progs-3.16.1 )
device-mapper? ( >=sys-fs/lvm2-2.02.89[thin] )
seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+ systemd? ( sys-apps/systemd )
"
# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#runtime-dependencies
@@ -55,6 +56,7 @@ S="${WORKDIR}/${P}/src/${EGO_PN}"
# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
PATCHES=(
"${FILESDIR}/0001-Openrc-Depend-on-containerd-init-script.patch"
+ "${FILESDIR}/docker-24.0.5-automagic-systemd.patch"
)
pkg_setup() {
@@ -264,6 +266,8 @@ src_compile() {
fi
done
+ export SYSTEMD=$(usex systemd 1 0)
+
# build binaries
./hack/make.sh dynbinary || die 'dynbinary failed'
}
diff --git a/app-containers/docker/docker-26.1.0.ebuild b/app-containers/docker/docker-26.1.0-r1.ebuild
index 6a2110fa66a5..9a1e51a65f67 100644
--- a/app-containers/docker/docker-26.1.0.ebuild
+++ b/app-containers/docker/docker-26.1.0-r1.ebuild
@@ -54,6 +54,7 @@ S="${WORKDIR}/${P}/src/${EGO_PN}"
# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
PATCHES=(
"${FILESDIR}/0001-Openrc-Depend-on-containerd-init-script.patch"
+ "${FILESDIR}/docker-26.1.0-automagic-systemd.patch"
)
pkg_setup() {
@@ -258,6 +259,8 @@ src_compile() {
fi
done
+ export SYSTEMD=$(usex systemd 1 0)
+
# build binaries
./hack/make.sh dynbinary || die 'dynbinary failed'
}
diff --git a/app-containers/docker/files/docker-24.0.5-automagic-systemd.patch b/app-containers/docker/files/docker-24.0.5-automagic-systemd.patch
new file mode 100644
index 000000000000..fb764b3b1a99
--- /dev/null
+++ b/app-containers/docker/files/docker-24.0.5-automagic-systemd.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/914076
+https://github.com/moby/moby/issues/47770
+--- a/hack/make.sh
++++ b/hack/make.sh
+@@ -90,7 +90,7 @@ add_buildtag() {
+ [[ " $DOCKER_BUILDTAGS" == *" $1_"* ]] || DOCKER_BUILDTAGS+=" $1_$2"
+ }
+
+-if ${PKG_CONFIG} 'libsystemd' 2> /dev/null; then
++if [[ -n "$SYSTEMD" ]] && [[ "$SYSTEMD" == 1 ]] && ${PKG_CONFIG} 'libsystemd' 2> /dev/null; then
+ DOCKER_BUILDTAGS+=" journald"
+ fi
+
diff --git a/app-containers/docker/files/docker-26.1.0-automagic-systemd.patch b/app-containers/docker/files/docker-26.1.0-automagic-systemd.patch
new file mode 100644
index 000000000000..004dbb9ad3c7
--- /dev/null
+++ b/app-containers/docker/files/docker-26.1.0-automagic-systemd.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/914076
+https://github.com/moby/moby/issues/47770
+--- a/hack/make.sh
++++ b/hack/make.sh
+@@ -83,7 +83,7 @@ if [ ! "$GOPATH" ]; then
+ exit 1
+ fi
+
+-if ${PKG_CONFIG} 'libsystemd' 2> /dev/null; then
++if [[ -n "$SYSTEMD" ]] && [[ "$SYSTEMD" == 1 ]] && ${PKG_CONFIG} 'libsystemd' 2> /dev/null; then
+ DOCKER_BUILDTAGS+=" journald"
+ fi
+