summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-04-21 22:50:30 -0700
committerZac Medico <zmedico@gentoo.org>2024-04-21 22:50:57 -0700
commitdd3df74b260c383ca385badbf0d60b4806f26318 (patch)
tree4fcaafb6f8735482da372483093b34003ab25934 /app-containers
parentgui-libs/wpebackend-fdo: Update dep for media-libs/libepoxy[egl] IUSE removal (diff)
downloadgentoo-dd3df74b260c383ca385badbf0d60b4806f26318.tar.gz
gentoo-dd3df74b260c383ca385badbf0d60b4806f26318.tar.bz2
gentoo-dd3df74b260c383ca385badbf0d60b4806f26318.zip
app-containers/cri-o: drop 1.26.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/cri-o/Manifest1
-rw-r--r--app-containers/cri-o/cri-o-1.26.0.ebuild102
2 files changed, 0 insertions, 103 deletions
diff --git a/app-containers/cri-o/Manifest b/app-containers/cri-o/Manifest
index 416317049881..34d6af512fea 100644
--- a/app-containers/cri-o/Manifest
+++ b/app-containers/cri-o/Manifest
@@ -1,2 +1 @@
-DIST cri-o-1.26.0.tar.gz 28306997 BLAKE2B aa4eb7b9964456ff95572e3e8f4f791141956863b13bb9b0eb3507321b76ef7e815f6a27f003f9265ffdfbeaf59a8f3e291187314ec2137dde741143cbcead2f SHA512 489cd0b3989764f48d8803e65e152515d77326f3f794cec02f694825fc6e5b0541d3608253d5e8a399c9119e85fa947fc62558b4656bf6a189c52e0bef4d669e
DIST cri-o-1.29.0.tar.gz 21371695 BLAKE2B f670605f07446a78ce04f497207e0205aee23138be448bdc2d2fb172691e5bb309234daa1c5c0adbb37dcb24e9177f24f62e01e183ac6443f48054b9e65b6dfe SHA512 bb83c906964e61ae68219e1374a3e0810fc982fd0389549e6fe3128156af8d5c6effce4217de4d33d3e29e986db630525694093ca3a99b6065385e1e37927fef
diff --git a/app-containers/cri-o/cri-o-1.26.0.ebuild b/app-containers/cri-o/cri-o-1.26.0.ebuild
deleted file mode 100644
index d2510ed1b0e5..000000000000
--- a/app-containers/cri-o/cri-o-1.26.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_COMMIT=214b77367c48acd75a08610ac8d0941540347691
-
-inherit go-module
-
-DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
-HOMEPAGE="https://cri-o.io/"
-SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs +device-mapper selinux systemd"
-
-COMMON_DEPEND="
- app-crypt/gpgme:=
- app-containers/conmon
- app-containers/runc
- dev-libs/glib:=
- dev-libs/libassuan:=
- dev-libs/libgpg-error:=
- net-firewall/conntrack-tools
- net-firewall/iptables
- app-containers/cni-plugins
- net-misc/socat
- sys-apps/iproute2
- sys-libs/libseccomp:=
- btrfs? ( sys-fs/btrfs-progs )
- device-mapper? ( sys-fs/lvm2:= )
- selinux? ( sys-libs/libselinux:= )
- systemd? ( sys-apps/systemd:= )"
-DEPEND="
- ${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}
- !<app-containers/podman-1.3.2-r1
- selinux? ( sec-policy/selinux-crio )"
-
-src_prepare() {
- default
-
- sed -e '/^export GOPROXY=/d' \
- -e '/^GIT_.*/d' \
- -e '/ git diff --exit-code/d' \
- -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
- -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
- -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
- -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
- -i Makefile || die
-
- echo ".NOTPARALLEL: binaries docs" >> Makefile || die
-
- sed -e 's:/usr/local/bin:/usr/bin:' \
- -i contrib/systemd/* || die
-}
-
-src_compile() {
- [[ -f hack/btrfs_installed_tag.sh ]] || die
- use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
- hack/btrfs_installed_tag.sh || die; }
-
- [[ -f hack/libdm_installed.sh ]] || die
- use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
- hack/libdm_installed.sh || die; }
-
- [[ -f hack/selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- hack/selinux_tag.sh || die; }
-
- mkdir -p bin || die
- emake all \
- GOBIN="${S}/bin" \
- GO_BUILD="go build ${GOFLAGS}" \
- GO_MD2MAN="$(which go-md2man)"
-}
-
-src_install() {
- emake install install.config install.systemd \
- DESTDIR="${D}" \
- GO_MD2MAN="$(which go-md2man)" \
- PREFIX="${D}${EPREFIX}/usr"
- keepdir /etc/crio
- mv "${ED}/etc/crio/crio.conf"{,.example} || die
-
- newinitd "${FILESDIR}/crio.initd" crio
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
-
- # Suppress crio log error messages triggered if these don't exist.
- keepdir /etc/containers/oci/hooks.d
- keepdir /usr/share/containers/oci/hooks.d
-
- # Suppress crio "Missing CNI default network" log message.
- keepdir /etc/cni/net.d
- insinto /etc/cni/net.d
- doins contrib/cni/99-loopback.conflist
-}