summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-05-03 18:41:12 +0530
committerFlorian Schmaus <flow@gentoo.org>2024-05-09 12:51:40 +0200
commitfebb71169aad29b8f165ac9c19d7d69b05dfbad1 (patch)
treef9840d55b30314b9724c97b3199d76c524b69f55 /app-containers
parentdev-lang/scala: fix compilation error (diff)
downloadgentoo-febb71169aad29b8f165ac9c19d7d69b05dfbad1.tar.gz
gentoo-febb71169aad29b8f165ac9c19d7d69b05dfbad1.tar.bz2
gentoo-febb71169aad29b8f165ac9c19d7d69b05dfbad1.zip
app-containers/conmon: add 2.1.11
drop the patch as it got merged upstream https://github.com/containers/conmon/pull/456 https://github.com/containers/conmon/pull/482 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/36529 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/conmon/Manifest1
-rw-r--r--app-containers/conmon/conmon-2.1.11.ebuild49
-rw-r--r--app-containers/conmon/conmon-9999.ebuild5
3 files changed, 51 insertions, 4 deletions
diff --git a/app-containers/conmon/Manifest b/app-containers/conmon/Manifest
index a091bde18e70..0283970a03a4 100644
--- a/app-containers/conmon/Manifest
+++ b/app-containers/conmon/Manifest
@@ -1,2 +1,3 @@
DIST conmon-2.1.10.tar.gz 121047 BLAKE2B 14b4c2d541607eac0af6b335f35bd506c9a6c3d2b4e4e3ad79f32550385e90b6f7533f505565f90fb4bb1f42d528c41e9ddc7ec275c16ee982a6d0afe1c65bff SHA512 ecf1a961f431b005b54faa68b5c1bcf31d448f994ca66a56f13002216074dba79b53b52a377d4f8dab08141d6c6cf44467352fbff37175135d3da84081b27a18
+DIST conmon-2.1.11.tar.gz 121573 BLAKE2B 600a3e13eee5f71ef5f7aa21d9cf0184dd01c8e5e68d31aa35efcb08c3cf4305313fcfcf0aba3eedb243fe36f0e1e27f68a71627e2050c8ed4a73de273b98131 SHA512 47952f6cbbb810591d78c67856100be0edbf96d30328a10f22c3ec927bc6d1187540824c388d1fc7f3bb16fb7414339f3f20311d1baffb1fae1e38c4d5e7249c
DIST conmon-2.1.8.tar.gz 120541 BLAKE2B 8ae12e674edf49f233f7423f2566a1ddea793bd4fc888618a8903a84309cb4aacea9d200bb0f8e0895c96796dca9bc2e6e73c9c8a7dcc5f2c540b05f7a73a21e SHA512 a277de8f8adf001c3e3ef6ef19d4bade36d48c5395a624ee99cb22708ea26a9954df76362006a1331efc06265cb790883b43e84f0006f80c1725a7470ff244c3
diff --git a/app-containers/conmon/conmon-2.1.11.ebuild b/app-containers/conmon/conmon-2.1.11.ebuild
new file mode 100644
index 000000000000..e135e5acc8fe
--- /dev/null
+++ b/app-containers/conmon/conmon-2.1.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/conmon.git"
+else
+ SRC_URI="https://github.com/containers/conmon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+seccomp systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
+
+src_prepare() {
+ # PR 505 https://github.com/containers/conmon/pull/505
+ echo "${PV}" | tee VERSION || die
+
+ default
+ sed -i -e "s|shell.*--exists libsystemd.* && echo \"0\"|shell echo $(usex systemd 0 1)|g;" Makefile || die
+ echo -e "#!/usr/bin/env bash\necho $(usex seccomp 0 1)" > hack/seccomp-notify.sh || die
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ export PREFIX="${EPREFIX}/usr" GOMD2MAN=$(command -v go-md2man)
+ default
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym ../../bin/"${PN}" /usr/libexec/podman/"${PN}"
+}
diff --git a/app-containers/conmon/conmon-9999.ebuild b/app-containers/conmon/conmon-9999.ebuild
index c41813b997a1..bed057cb8f10 100644
--- a/app-containers/conmon/conmon-9999.ebuild
+++ b/app-containers/conmon/conmon-9999.ebuild
@@ -26,9 +26,6 @@ RDEPEND="dev-libs/glib:=
systemd? ( sys-apps/systemd:= )"
DEPEND="${RDEPEND}"
BDEPEND="dev-go/go-md2man"
-PATCHES=(
- "${FILESDIR}/conmon-2.1.8-Makefile.patch"
-)
src_prepare() {
default
@@ -38,7 +35,7 @@ src_prepare() {
src_compile() {
tc-export CC PKG_CONFIG
- export PREFIX="${EPREFIX}/usr" GOMD2MAN=go-md2man
+ export PREFIX="${EPREFIX}/usr" GOMD2MAN=$(command -v go-md2man)
default
}