summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-03 01:33:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-03 01:48:46 +0200
commit7383355e1cf76123cc50e787418970a7f5169849 (patch)
treebbb877ea8423bb7853ab6ad4ff3f8713fce7eeee /app-emacs/cape
parentsys-apps/inxi: Stabilize 3.3.27.1 ppc64, #909543 (diff)
downloadgentoo-7383355e1cf76123cc50e787418970a7f5169849.tar.gz
gentoo-7383355e1cf76123cc50e787418970a7f5169849.tar.bz2
gentoo-7383355e1cf76123cc50e787418970a7f5169849.zip
app-emacs/cape: bump to 0.16
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/cape')
-rw-r--r--app-emacs/cape/Manifest1
-rw-r--r--app-emacs/cape/cape-0.16.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
index b719c2277d70..e951f1371959 100644
--- a/app-emacs/cape/Manifest
+++ b/app-emacs/cape/Manifest
@@ -1 +1,2 @@
DIST cape-0.15.tar.xz 25848 BLAKE2B 44d72cd8de7597dad6f92c225995a5e1c02f42daf7a839c98e2b3d3ec0ff66dba5da64fc87d64b4913c5f9598cb00e3b46e22eaf98f65a759f4c04c9b373a3b2 SHA512 a2ea009f1f28868ac7c58f23e9212568545434588d89a2f15e5b1a0f4dba09a27a5620a9b9ac79cb88da3a9e83174f13a6122425581dd0aa43e25d12f1766396
+DIST cape-0.16.tar.gz 36845 BLAKE2B 13a7e1b79cbfcb027dd10e475a928782acf1b835161bc508b92390aa8bd932474ec85cb59c752b732952d71261236db853d0e7fa2f7c005a42c4037ddc11be9d SHA512 d668d438dd400928cd55f08a041a7493674d3118da8d78f6968cd9d41f12d8d654525ee7c15d5edf68d93e16815f8a2dfc96e4d850bbf624339380158fd9625c
diff --git a/app-emacs/cape/cape-0.16.ebuild b/app-emacs/cape/cape-0.16.ebuild
new file mode 100644
index 000000000000..16b63bbdfda8
--- /dev/null
+++ b/app-emacs/cape/cape-0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}