summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-17 15:01:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-17 15:22:11 +0200
commit8274576f04850cf82351344edda84526d7300878 (patch)
tree88af656e49ce16ff6da9c39931e929092a0aa062 /app-emacs/cape
parentapp-emacs/doom-modeline: drop old 3.3.2 (diff)
downloadgentoo-8274576f04850cf82351344edda84526d7300878.tar.gz
gentoo-8274576f04850cf82351344edda84526d7300878.tar.bz2
gentoo-8274576f04850cf82351344edda84526d7300878.zip
app-emacs/cape: bump to 0.17
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/cape')
-rw-r--r--app-emacs/cape/Manifest1
-rw-r--r--app-emacs/cape/cape-0.17.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
index 3d9029021a15..7ace52485d66 100644
--- a/app-emacs/cape/Manifest
+++ b/app-emacs/cape/Manifest
@@ -1 +1,2 @@
DIST cape-0.16.tar.gz 36845 BLAKE2B 13a7e1b79cbfcb027dd10e475a928782acf1b835161bc508b92390aa8bd932474ec85cb59c752b732952d71261236db853d0e7fa2f7c005a42c4037ddc11be9d SHA512 d668d438dd400928cd55f08a041a7493674d3118da8d78f6968cd9d41f12d8d654525ee7c15d5edf68d93e16815f8a2dfc96e4d850bbf624339380158fd9625c
+DIST cape-0.17.tar.gz 37495 BLAKE2B 180d52f17e0a21238d59aa2a42069ca914a036b26868be01727eeb4f2ba5fbb7db733e5b86a00ee84bf8a63fe14e8930893804afc1979edd345cc344e561ff77 SHA512 bcf648e26749893d0c10538709b8c06885be0d96f85c9039749722cf46875d87f01b075d8058e17e68e240e7b099252e69ecd7fd3206dadee010c176296320df
diff --git a/app-emacs/cape/cape-0.17.ebuild b/app-emacs/cape/cape-0.17.ebuild
new file mode 100644
index 000000000000..16b63bbdfda8
--- /dev/null
+++ b/app-emacs/cape/cape-0.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}