summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-10 15:03:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-10 15:37:11 +0200
commit7a22b91d6826d94356ded0c17d6250ad9d3488b7 (patch)
tree11a8cf1f2bb77200ae4d87fe9f623b20759dc13f /app-emacs/citeproc-el
parentapp-emacs/yaml: new package; add version 0.5.1 (diff)
downloadgentoo-7a22b91d6826d94356ded0c17d6250ad9d3488b7.tar.gz
gentoo-7a22b91d6826d94356ded0c17d6250ad9d3488b7.tar.bz2
gentoo-7a22b91d6826d94356ded0c17d6250ad9d3488b7.zip
app-emacs/citeproc-el: new package; add version 0.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/citeproc-el')
-rw-r--r--app-emacs/citeproc-el/Manifest1
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild47
-rw-r--r--app-emacs/citeproc-el/files/50citeproc-el-gentoo.el1
-rw-r--r--app-emacs/citeproc-el/metadata.xml27
4 files changed, 76 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
new file mode 100644
index 000000000000..385d6a355b8d
--- /dev/null
+++ b/app-emacs/citeproc-el/Manifest
@@ -0,0 +1 @@
+DIST citeproc-el-0.9.1.tar.gz 108702 BLAKE2B 409548f50baa37c03906d3435569b8f75d8f0238b2d463e22ab0428a0536c6b12e2bf723a8fc4684fae17b31a9d46121d0ebcfd3cd03ada5b0838c8f0e042106 SHA512 6eab58576b4f851f44b45e444ee43a9022651dd322efa77b6162db0906a8cace70458b0a1431ed3d995d480d38944bafc13e76e04e5a310e8c14ffc28888953f
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
new file mode 100644
index 000000000000..b59dcf28c0e8
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/citeproc-el/metadata.xml b/app-emacs/citeproc-el/metadata.xml
new file mode 100644
index 000000000000..33a57a1b947e
--- /dev/null
+++ b/app-emacs/citeproc-el/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ citeproc-el is an Emacs Lisp library for rendering citations and
+ bibliographies in styles described in the Citation Style Language (CSL), an
+ XML-based, open format to describe the formatting of bibliographic
+ references (see http://citationstyles.org/ for further information on CSL).
+ The library implements most of the CSL 1.0.2 specification, including such
+ features as citation disambiguation, cite collapsing and subsequent author
+ substitution, and passes more than 70% of the tests in the CSL Test Suite.
+ In addition to the standard CSL-JSON data format, citeproc-el has
+ rudimentary support for reading bibliographic data from BibTeX, biblatex
+ and org-bibtex bibliographies and can produce output in several formats
+ including HTML and org-mode markup (see Supported output formats for the
+ full list).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/andras-simonyi/citeproc-el/issues/</bugs-to>
+ <remote-id type="github">andras-simonyi/citeproc-el</remote-id>
+ </upstream>
+</pkgmetadata>