summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-05 03:38:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-05 04:02:07 +0100
commitf36329d235426876661371f0430cf0495364c817 (patch)
tree4eb7f6090039c85a67d63c80dca68cb6ada5ecbe /app-emacs/citeproc-el
parentapp-office/denaro: bump to 2024.1.0 (diff)
downloadgentoo-f36329d235426876661371f0430cf0495364c817.tar.gz
gentoo-f36329d235426876661371f0430cf0495364c817.tar.bz2
gentoo-f36329d235426876661371f0430cf0495364c817.zip
app-emacs/citeproc-el: bump to 0.9.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/citeproc-el')
-rw-r--r--app-emacs/citeproc-el/Manifest1
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
index 688466a5ea7e..01d6ee230ca6 100644
--- a/app-emacs/citeproc-el/Manifest
+++ b/app-emacs/citeproc-el/Manifest
@@ -1 +1,2 @@
DIST citeproc-el-0.9.3.tar.gz 109131 BLAKE2B f6975cd587f61f5f05bfc3734e70ec686a3e26caa4b7905b5b4377c4ce6c8eae5199ea097de9abb10dd1a649587cf016c5fe0db4a6fd4012867655702f5004d8 SHA512 98275ef7ba0a7fc5d866ee010b5f4c8ecf75b12857c6355da07345957783815d9012f8aa86fd7462b8a08e4e3f3192853e1b4a0d5a0088acdb89476011375083
+DIST citeproc-el-0.9.4.tar.gz 109594 BLAKE2B f13c1c93110666d897127c31da39eee392161fada18aa5cee940dfe4968b565d45a397536aa3d8c902625be6c3b27d4a19fca4aeab83233fb549c3f35169adcd SHA512 6772fea40203221e7016a5a0a5c2522b72889202f89eef4603dcbdb8c3c8c0050c5aabee8d56d5e56148e100fac33cd24489d3e03f2caa85964796b7d89ae019
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
new file mode 100644
index 000000000000..15506aca0ab1
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}