summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-15 21:52:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-15 22:20:43 +0100
commit1789819e1cef78c112b927376e1358c8d392502f (patch)
tree5e3775fe68e159b64c592b9e8fa24a3109795a0a /app-emacs/emms
parentapp-emacs/emms: drop old 16 (diff)
downloadgentoo-1789819e1cef78c112b927376e1358c8d392502f.tar.gz
gentoo-1789819e1cef78c112b927376e1358c8d392502f.tar.bz2
gentoo-1789819e1cef78c112b927376e1358c8d392502f.zip
app-emacs/emms: bump to 18
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emms')
-rw-r--r--app-emacs/emms/Manifest1
-rw-r--r--app-emacs/emms/emms-18.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/emms/Manifest b/app-emacs/emms/Manifest
index 32377f86499f..36ecbada6bdf 100644
--- a/app-emacs/emms/Manifest
+++ b/app-emacs/emms/Manifest
@@ -1 +1,2 @@
DIST emms-17.tar.gz 263213 BLAKE2B 0a72de7a59e2db9fb6a4fbfc78bc5417c0826d1719905063c0d037a424f73500e45de469850940ab3ce072b1c7a747bb65020a061d23a693706ba0894f7a441c SHA512 b8c6c2ee6e59214a6c2647b3ea4dac3a96ab6d5da7b0aa6890503621242ea7e56e91c27e4f8ccc20ed6def76ebd8be79633654067d39bfd9b2d5d831d31f2805
+DIST emms-18.tar.gz 261059 BLAKE2B 93758279d12c96fb268557d60743f7c415724e9869073f4ac5d3c6aa8c755723f50d93c8fb3517a1f1266f5f1daf76796164b7b1b64f618170a53cbd6bc317eb SHA512 771dd5c6ca4ecc65f6108d8dabe5755aefd8ca6cf3ba766c4310227c44e95e22fdfd7415aa30f82b5f7b4b4be5c413fa576fdf6c59ab5e0647fa675d98a1cf9a
diff --git a/app-emacs/emms/emms-18.ebuild b/app-emacs/emms/emms-18.ebuild
new file mode 100644
index 000000000000..ee43f01fcdd9
--- /dev/null
+++ b/app-emacs/emms/emms-18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="https://git.savannah.gnu.org/cgit/emms.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ media-libs/taglib
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ exeinto /usr/bin
+ doexe src/emms-print-metadata
+
+ doinfo doc/emms.info*
+ doman emms-print-metadata.1
+
+ einstalldocs
+}