summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/emms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/emms')
-rw-r--r--app-emacs/emms/Manifest1
-rw-r--r--app-emacs/emms/emms-3.0-r1.ebuild41
-rw-r--r--app-emacs/emms/files/50emms-gentoo.el2
-rw-r--r--app-emacs/emms/files/emms-3.0-Makefile.patch11
-rw-r--r--app-emacs/emms/files/emms-3.0-texinfo-5.patch17
-rw-r--r--app-emacs/emms/metadata.xml16
6 files changed, 88 insertions, 0 deletions
diff --git a/app-emacs/emms/Manifest b/app-emacs/emms/Manifest
new file mode 100644
index 000000000000..3f83855dd85a
--- /dev/null
+++ b/app-emacs/emms/Manifest
@@ -0,0 +1 @@
+DIST emms-3.0.tar.gz 200838 SHA256 5b750312dc82f856b1c725c0d795216f430ef7c25a301cda75b4847e52773594 SHA512 a6637d6d9bcf7fdc81815e698b51579d2dcb51b70b39d65117a81d180541f4774c82a1da23f5e67a5ffd37d5f1a4ce4fe5f653f8e443f899910320eaf5420119 WHIRLPOOL b8f9eecf1c1883e59051a31076888abb038627960012c22d9822764d558e84d97afb0b3eee9c6bf3fe89b707c6657d62099b384cac684709f1250f8fe63e9c59
diff --git a/app-emacs/emms/emms-3.0-r1.ebuild b/app-emacs/emms/emms-3.0-r1.ebuild
new file mode 100644
index 000000000000..7144d852819a
--- /dev/null
+++ b/app-emacs/emms/emms-3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="http://www.gnu.org/software/emms/
+ http://www.emacswiki.org/emacs/EMMS"
+SRC_URI="http://www.gnu.org/software/emms/download/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="media-libs/taglib"
+RDEPEND="${DEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+ELISP_PATCHES="${P}-Makefile.patch
+ ${P}-texinfo-5.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ EMACS=emacs \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo *.info*
+ dobin *-wrapper emms-print-metadata
+ dodoc AUTHORS ChangeLog FAQ NEWS README RELEASE
+}
diff --git a/app-emacs/emms/files/50emms-gentoo.el b/app-emacs/emms/files/50emms-gentoo.el
new file mode 100644
index 000000000000..9749f5e1e866
--- /dev/null
+++ b/app-emacs/emms/files/50emms-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'emms-auto)
diff --git a/app-emacs/emms/files/emms-3.0-Makefile.patch b/app-emacs/emms/files/emms-3.0-Makefile.patch
new file mode 100644
index 000000000000..4f5760c162b3
--- /dev/null
+++ b/app-emacs/emms/files/emms-3.0-Makefile.patch
@@ -0,0 +1,11 @@
+--- emms-3.0-orig/Makefile 2007-06-29 18:16:24.000000000 +0200
++++ emms-3.0/Makefile 2010-08-09 22:14:39.000000000 +0200
+@@ -41,7 +41,7 @@
+ makeinfo --html --no-split $<
+
+ emms-print-metadata: emms-print-metadata.c
+- $(CC) -o $@ $< -I/usr/include/taglib -L/usr/lib -ltag_c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< `taglib-config --libs --cflags` -ltag_c
+
+ install:
+ test -d $(SITELISP) || mkdir -p $(SITELISP)
diff --git a/app-emacs/emms/files/emms-3.0-texinfo-5.patch b/app-emacs/emms/files/emms-3.0-texinfo-5.patch
new file mode 100644
index 000000000000..10ee2ad57524
--- /dev/null
+++ b/app-emacs/emms/files/emms-3.0-texinfo-5.patch
@@ -0,0 +1,17 @@
+--- emms-3.0-orig/gpl.texi
++++ emms-3.0/gpl.texi
+@@ -659,6 +659,8 @@
+ Program, unless a warranty or assumption of liability accompanies a
+ copy of the Program in return for a fee.
+
++@end enumerate
++
+ @iftex
+ @heading END OF TERMS AND CONDITIONS
+ @end iftex
+@@ -721,5 +723,3 @@
+ applications with the library. If this is what you want to do, use
+ the GNU Lesser General Public License instead of this License. But
+ first, please read @url{http://www.gnu.org/philosophy/why-not-lgpl.html}.
+-
+-@end enumerate
diff --git a/app-emacs/emms/metadata.xml b/app-emacs/emms/metadata.xml
new file mode 100644
index 000000000000..bff8c8626d37
--- /dev/null
+++ b/app-emacs/emms/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ EMMS, the Emacs Multimedia System, is an extensible, light-weight
+ multimedia player system for Emacs. It includes support for audio
+ and video formats such as MP3, FLAC, Ogg Vorbis, MPEG, WMV, MOV,
+ AVI, OGM, MKV via external players such as MPlayer, GStreamer,
+ mpg321, ogg123 etc.
+
+ EMMS also includes meta data tagging capabilities (including batched
+ tagging), play-list management, play-list scoring, streamed media
+ and support for synchronized song lyrics display.
+</longdescription>
+</pkgmetadata>