summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-15 21:07:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-15 21:08:16 +0200
commitba8996a52edf1c89fc8404ab8c833ce7d729a2ae (patch)
treeb26ffe7803b4a297d9dfa453765654d777b23b73 /app-emacs/git-modes
parentapp-emacs/ghub: bump to 3.6.0 (diff)
downloadgentoo-ba8996a52edf1c89fc8404ab8c833ce7d729a2ae.tar.gz
gentoo-ba8996a52edf1c89fc8404ab8c833ce7d729a2ae.tar.bz2
gentoo-ba8996a52edf1c89fc8404ab8c833ce7d729a2ae.zip
app-emacs/git-modes: bump to 1.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/git-modes')
-rw-r--r--app-emacs/git-modes/Manifest1
-rw-r--r--app-emacs/git-modes/git-modes-1.4.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/git-modes/Manifest b/app-emacs/git-modes/Manifest
index bfe64fec76b7..5f1f8e28ecc2 100644
--- a/app-emacs/git-modes/Manifest
+++ b/app-emacs/git-modes/Manifest
@@ -1 +1,2 @@
DIST git-modes-1.4.0.tar.gz 18218 BLAKE2B 7e08ce42d683d4a8224df6255304e3beb7db2a5d97f6c758bf229e020dd3c0e5ed5f75acf9a7fdf8a5d313b904cc59d0de1419244067a5975d5174f45aca0071 SHA512 2511575a4d5d578fca5bde50e103d0fe777eed9bc3c520d5172aff7c65baa47a0a0f633e0950b7efb3eaa891debd3e34df3612d713412d547bb58733c9f00cbc
+DIST git-modes-1.4.1.tar.gz 18445 BLAKE2B 99353090333aae538fc5daa7c8e127ac58b518c03e871d7f397b716110fcbbd45d553e4e67ad6dfe8c874054c471fc0e018e890e6c0487eea4d1559de54e4e71 SHA512 374b2ea09af62a3b30084206e51f05989c6fd8e7e2435253e4d676f4ea3ec020d56681e2bd41db75a395ad677e5686744ca7e425a7a33eaa7d4d0a1a3d337d41
diff --git a/app-emacs/git-modes/git-modes-1.4.1.ebuild b/app-emacs/git-modes/git-modes-1.4.1.ebuild
new file mode 100644
index 000000000000..75f248bff469
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+SRC_URI="https://github.com/magit/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}