summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-20 20:39:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-20 20:45:47 +0100
commit962176ac05c225f4da3b2b5f54f14dd7160552e5 (patch)
tree6c23d3f352c99d7e87dc39da0e9318ea8bd7ad00 /app-emacs/indent-bars
parentapp-emacs/package-lint: add new dependency for 0.21 - compat (diff)
downloadgentoo-962176ac05c225f4da3b2b5f54f14dd7160552e5.tar.gz
gentoo-962176ac05c225f4da3b2b5f54f14dd7160552e5.tar.bz2
gentoo-962176ac05c225f4da3b2b5f54f14dd7160552e5.zip
app-emacs/indent-bars: add new dependency for 0.2 - compat
Closes: https://bugs.gentoo.org/920386 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/indent-bars')
-rw-r--r--app-emacs/indent-bars/indent-bars-0.2-r1.ebuild35
-rw-r--r--app-emacs/indent-bars/indent-bars-0.2.ebuild21
2 files changed, 35 insertions, 21 deletions
diff --git a/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild b/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild
new file mode 100644
index 000000000000..59407095b39d
--- /dev/null
+++ b/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Fast, configurable indentation guide-bars for Emacs"
+HOMEPAGE="https://github.com/jdtsmith/indent-bars/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/compat
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md examples.md )
diff --git a/app-emacs/indent-bars/indent-bars-0.2.ebuild b/app-emacs/indent-bars/indent-bars-0.2.ebuild
deleted file mode 100644
index 2f46c530c735..000000000000
--- a/app-emacs/indent-bars/indent-bars-0.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-NEED_EMACS=27.1
-
-inherit elisp
-
-IUSE=""
-
-DESCRIPTION="Fast, configurable indentation guide-bars for Emacs"
-HOMEPAGE="https://github.com/jdtsmith/indent-bars"
-SRC_URI="https://github.com/jdtsmith/indent-bars/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-SITEFILE="50${PN}-gentoo.el"
-
-DOCS="examples.md README.md"