summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/lookup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/lookup')
-rw-r--r--app-emacs/lookup/Manifest1
-rw-r--r--app-emacs/lookup/files/50lookup-gentoo.el4
-rw-r--r--app-emacs/lookup/files/lookup-1.4.1-garbage-char.patch8
-rw-r--r--app-emacs/lookup/lookup-1.4.1.ebuild34
-rw-r--r--app-emacs/lookup/metadata.xml6
5 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/lookup/Manifest b/app-emacs/lookup/Manifest
new file mode 100644
index 000000000000..f6871f255324
--- /dev/null
+++ b/app-emacs/lookup/Manifest
@@ -0,0 +1 @@
+DIST lookup-1.4.1.tar.gz 346391 SHA256 13ab02652e322773f279db1862e4423c24da0da0b662dd6a29dbd95aca729bfa SHA512 a28a770ba58f07db5a7b2452792fc0e83b74e3b45556e84a9729c73773df661dbb7d356c1f7be803feb66f23e154aa825dab610f841bbe655bc76bd7120370bf WHIRLPOOL 2096df15468826cdd69b53210c3e86cd83823dbc4c5cc4b16f438732a4ddc21e902a057f60a5d076b319b977f485a2b7badd5d8983c79c0b04822c8fa0f00746
diff --git a/app-emacs/lookup/files/50lookup-gentoo.el b/app-emacs/lookup/files/50lookup-gentoo.el
new file mode 100644
index 000000000000..9ae8d93a847c
--- /dev/null
+++ b/app-emacs/lookup/files/50lookup-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'lookup "lookup" nil t)
+(autoload 'lookup-region "lookup" nil t)
+(autoload 'lookup-pattern "lookup" nil t)
diff --git a/app-emacs/lookup/files/lookup-1.4.1-garbage-char.patch b/app-emacs/lookup/files/lookup-1.4.1-garbage-char.patch
new file mode 100644
index 000000000000..7c9a3bea9152
--- /dev/null
+++ b/app-emacs/lookup/files/lookup-1.4.1-garbage-char.patch
@@ -0,0 +1,8 @@
+--- lookup-1.4.1-orig/lisp/ndic.el
++++ lookup-1.4.1/lisp/ndic.el
+@@ -1,4 +1,4 @@
+-e;;; ndic.el --- Lookup by free dictionaries
++;;; ndic.el --- Lookup by free dictionaries
+ ;; Copyright (C) 1999 Lookup Development Team <lookup@ring.gr.jp>
+
+ ;; Author: Keisuke Nishida <kei@psn.net>
diff --git a/app-emacs/lookup/lookup-1.4.1.ebuild b/app-emacs/lookup/lookup-1.4.1.ebuild
new file mode 100644
index 000000000000..39ad4cd0c8df
--- /dev/null
+++ b/app-emacs/lookup/lookup-1.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="An interface to search CD-ROM books and network dictionaries"
+HOMEPAGE="http://openlab.jp/edict/lookup/"
+SRC_URI="http://openlab.jp/edict/lookup/dist/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+ELISP_PATCHES="${P}-garbage-char.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+}
+
+src_compile() {
+ # parallel make fails with Emacs deadlock
+ emake -j1
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/app-emacs/lookup/metadata.xml b/app-emacs/lookup/metadata.xml
new file mode 100644
index 000000000000..92d4e62095de
--- /dev/null
+++ b/app-emacs/lookup/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>cjk</herd>
+</pkgmetadata>