summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 03:13:58 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 05:00:53 +0200
commit2a7c733537be79a0b295a94ade99e762a5bb7e02 (patch)
tree1dc178e971b6881b7531ae91db0aed5d90ebf05f /app-emacs/shut-up
parentapp-text/enchant: Version bump to 2.3.3 (diff)
downloadgentoo-2a7c733537be79a0b295a94ade99e762a5bb7e02.tar.gz
gentoo-2a7c733537be79a0b295a94ade99e762a5bb7e02.tar.bz2
gentoo-2a7c733537be79a0b295a94ade99e762a5bb7e02.zip
app-emacs/shut-up: new package; add version 0.3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/shut-up')
-rw-r--r--app-emacs/shut-up/Manifest1
-rw-r--r--app-emacs/shut-up/files/50shut-up-gentoo.el1
-rw-r--r--app-emacs/shut-up/metadata.xml13
-rw-r--r--app-emacs/shut-up/shut-up-0.3.3.ebuild33
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/shut-up/Manifest b/app-emacs/shut-up/Manifest
new file mode 100644
index 000000000000..e8adbe6988e5
--- /dev/null
+++ b/app-emacs/shut-up/Manifest
@@ -0,0 +1 @@
+DIST shut-up-0.3.3.tar.gz 4479 BLAKE2B 0cb9ee028386ceb9b80385a6893c203481a79619f8780c641ca76a8878bece3944973ba78a41e1a554d4c9402ec2227d1234a9b6862b01d489dba30db021b731 SHA512 b14110022bd1512985fe40194c419f06cc8f5f6c819f02e681a89c2f80a32140e20eea6e3bb659b1abee85021b01bdc0b48d3ff12d6fac6072635fbdcb808484
diff --git a/app-emacs/shut-up/files/50shut-up-gentoo.el b/app-emacs/shut-up/files/50shut-up-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shut-up/files/50shut-up-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shut-up/metadata.xml b/app-emacs/shut-up/metadata.xml
new file mode 100644
index 000000000000..ed648c38c11b
--- /dev/null
+++ b/app-emacs/shut-up/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/cask/shut-up/issues/</bugs-to>
+ <remote-id type="github">cask/shut-up</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shut-up/shut-up-0.3.3.ebuild b/app-emacs/shut-up/shut-up-0.3.3.ebuild
new file mode 100644
index 000000000000..f5a6d10ba523
--- /dev/null
+++ b/app-emacs/shut-up/shut-up-0.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Reduce Emacs output of messages"
+HOMEPAGE="https://github.com/cask/shut-up/"
+SRC_URI="https://github.com/cask/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/f
+ app-emacs/s
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}