summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/w3mnav
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/w3mnav')
-rw-r--r--app-emacs/w3mnav/Manifest1
-rw-r--r--app-emacs/w3mnav/files/75w3mnav-gentoo.el12
-rw-r--r--app-emacs/w3mnav/metadata.xml12
-rw-r--r--app-emacs/w3mnav/w3mnav-0.5-r3.ebuild25
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/w3mnav/Manifest b/app-emacs/w3mnav/Manifest
new file mode 100644
index 000000000000..c6cd1723666c
--- /dev/null
+++ b/app-emacs/w3mnav/Manifest
@@ -0,0 +1 @@
+DIST w3mnav-0.5.tar.gz 2378 SHA256 23ca6c96bd15e66c4311fd47fdc3e21671369a7e6fa7835ed6d7e895ff2f2581 SHA512 8b04d31307e6fccdfb0d5ebd9bc4c2b52d347c5c2c022ad9b3f342b4c2666858ac201e11acd7a15b77b22dbef287c0cf481119ea18443776b00e5b133431e723 WHIRLPOOL bfc79429c052df6dd5c0a13401453341c305703e648f8fdeef52495a3f42af0b80984a2de100f24dd908d6d29bd0ed00a7cfc74782531b5357b5b9e1d3159cdd
diff --git a/app-emacs/w3mnav/files/75w3mnav-gentoo.el b/app-emacs/w3mnav/files/75w3mnav-gentoo.el
new file mode 100644
index 000000000000..873b58e0d3dd
--- /dev/null
+++ b/app-emacs/w3mnav/files/75w3mnav-gentoo.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'w3m-nav-go-top "w3mnav" nil t)
+(autoload 'w3m-nav-go-prev "w3mnav" nil t)
+(autoload 'w3m-nav-go-next "w3mnav" nil t)
+
+(add-hook 'w3m-mode-hook
+ (lambda ()
+ (setq w3m-mode-map w3m-info-like-map)
+ (define-key w3m-mode-map "t" 'w3m-nav-go-top)
+ (define-key w3m-mode-map "[" 'w3m-nav-go-prev)
+ (define-key w3m-mode-map "]" 'w3m-nav-go-next)))
diff --git a/app-emacs/w3mnav/metadata.xml b/app-emacs/w3mnav/metadata.xml
new file mode 100644
index 000000000000..affa9b85b291
--- /dev/null
+++ b/app-emacs/w3mnav/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+w3mnav.el is an Emacs add-on that kludges some Info-like navigation keys to the
+w3m Web browser. This functionality was originally part of the Scheme support
+package Quack, and was intended to work with the numerous Scheme books that were
+converted to HTML from LaTeX format. It also works with some other HTML pages
+that have book-like &quot;next page&quot; and &quot;previous page&quot; links.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild b/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
new file mode 100644
index 000000000000..5c8464f120d7
--- /dev/null
+++ b/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Add Info-like navigation keys to the emacs-w3m web browser"
+HOMEPAGE="http://www.neilvandyke.org/w3mnav/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-emacs/emacs-w3m"
+RDEPEND="${DEPEND}"
+
+SITEFILE="75${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} -L "${SITELISP}/emacs-w3m" \
+ -f batch-byte-compile w3mnav.el || die "byte-compile failed"
+}