summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-02-14 21:47:27 +0100
committerSam James <sam@gentoo.org>2024-04-19 13:23:53 +0100
commit647ba57151666bc4d1809b6b41f2251d8cfb0157 (patch)
tree2163ccb26c5911fcf023ce7f86543986c5f7aa3c /app-forensics
parentdev-cpp/tbb: add 2021.12.0 (diff)
downloadgentoo-647ba57151666bc4d1809b6b41f2251d8cfb0157.tar.gz
gentoo-647ba57151666bc4d1809b6b41f2251d8cfb0157.tar.bz2
gentoo-647ba57151666bc4d1809b6b41f2251d8cfb0157.zip
app-forensics/yara: add 4.5.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.5.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 99cd2a2bb4b6..a117491f13c3 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1 +1,2 @@
DIST yara-4.4.0.tar.gz 2220068 BLAKE2B f9654592f3dbe493dc31bcda80c9f0e31a2a8998f47d1172afe7456a9d4ead8f475e3f0999140c952343cdeca1cedc8060a3b42c1bbe57ce617fd5b5a86dbfb3 SHA512 705db57b73e5165a26e0aaea728521f372b9f7f613665860dd22066c30e75a614815fb17ee8654780fcfc157f0137cbeda015ec088a698f31adcf071e233205f
+DIST yara-4.5.0.tar.gz 2206492 BLAKE2B 788ed6c4989bbc2d0a113b46bcd1291e7544ab8f56ebe499725163b7b02feb016935210e8a08d9cb179fbffc09fafb461cc55156101d9616a23a480a78862d9e SHA512 c9fe8a89879d1a742236101f1754e6b25e70356cdf5c020b2583e3ac509600c3b462756c412b01f2ebcb17df351c83afcf04d1cfaa87e6753eb25bab0f797aa3
diff --git a/app-forensics/yara/yara-4.5.0.ebuild b/app-forensics/yara/yara-4.5.0.ebuild
new file mode 100644
index 000000000000..e5874a8e7202
--- /dev/null
+++ b/app-forensics/yara/yara-4.5.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="https://virustotal.github.io/yara/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
+else
+ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}