summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-09-14 00:41:16 +0530
committerSam James <sam@gentoo.org>2022-09-14 23:28:48 +0100
commit4446f9b14a8208c2a826d5b6920490dd13165403 (patch)
tree316333d290fc1af7d45a69b702f65beaf773ae6f /app-office/abiword
parentdev-python/leechcorepyc: remove unused patch (diff)
downloadgentoo-4446f9b14a8208c2a826d5b6920490dd13165403.tar.gz
gentoo-4446f9b14a8208c2a826d5b6920490dd13165403.tar.bz2
gentoo-4446f9b14a8208c2a826d5b6920490dd13165403.zip
app-office/abiword: Fix lose precision on musl
abiword fails on musl with loses precision error for code `*pWindowName = (char) NULL`. This patch fixes it. Patch is taken from Gentoo dev ernsteiswuerfel [1], also refer [2] [1]: https://853118.bugs.gentoo.org/attachment.cgi?id=786479 [2]: https://gitlab.gnome.org/World/AbiWord/-/commit/857cd86def49fe8557cfe123830c4d5a61eee732 Closes: https://bugs.gentoo.org/853118 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26467 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/abiword-3.0.5.ebuild1
-rw-r--r--app-office/abiword/files/abiword-3.0.5-musl-lose-precision-fix.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-3.0.5.ebuild b/app-office/abiword/abiword-3.0.5.ebuild
index 919b3748b85a..e0d085420c5d 100644
--- a/app-office/abiword/abiword-3.0.5.ebuild
+++ b/app-office/abiword/abiword-3.0.5.ebuild
@@ -84,6 +84,7 @@ PATCHES=(
"${WORKDIR}"/patches/${PN}-3.0.4-pygobject.patch
"${WORKDIR}"/patches/${PN}-3.0.4-asio-standalone-placeholders.patch
"${WORKDIR}"/patches/${PN}-3.0.4-c++17-dynamic-exception-specifications.patch
+ "${FILESDIR}"/${PN}-3.0.5-musl-lose-precision-fix.patch
)
src_prepare() {
diff --git a/app-office/abiword/files/abiword-3.0.5-musl-lose-precision-fix.patch b/app-office/abiword/files/abiword-3.0.5-musl-lose-precision-fix.patch
new file mode 100644
index 000000000000..af2a33f0bbb8
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.5-musl-lose-precision-fix.patch
@@ -0,0 +1,37 @@
+# Patch written by fellow Gentoo user ernsteiswuerfel
+#
+# Please also reffer:
+# https://gitlab.gnome.org/World/AbiWord/-/commit/857cd86def49fe8557cfe123830c4d5a61eee732
+#
+# Closes: https://bugs.gentoo.org/853118
+--- a/src/af/xap/xp/xap_Dialog.cpp
++++ b/src/af/xap/xp/xap_Dialog.cpp
+@@ -36,8 +36,8 @@
+
+ XAP_Dialog::XAP_Dialog(XAP_DialogFactory * pDlgFactory, XAP_Dialog_Id id,
+ const char * helpUrl )
+- : m_pApp ( NULL ), m_pDlgFactory ( pDlgFactory ), m_id ( id ),
+- m_helpUrl(NULL)
++ : m_pApp ( nullptr ), m_pDlgFactory ( pDlgFactory ), m_id ( id ),
++ m_helpUrl(nullptr)
+ {
+ m_pApp = pDlgFactory->getApp();
+
+@@ -235,7 +235,7 @@ XAP_Frame * XAP_Dialog_Modeless::getActiveFrame(void) const
+ // This function returns the frame currently connected to a modeless dialog
+
+ XAP_Frame * pFrame = m_pApp->getLastFocussedFrame();
+- if(pFrame == (XAP_Frame *) NULL)
++ if(pFrame == (XAP_Frame *) nullptr)
+ {
+ pFrame = m_pApp->getFrame(0);
+ }
+@@ -267,7 +267,7 @@ XAP_Dialog_Modeless::BuildWindowName(char * pWindowName, const char * pDialogNam
+ // This function constructs and returns the window name of a modeless dialog by
+ // concatenating the active frame with the dialog name
+
+- *pWindowName = (char) NULL;
++ *pWindowName = (char) 0;
+ UT_UTF8String wn = UT_UTF8String(pDialogName);
+
+ XAP_Frame* pFrame = getActiveFrame();