summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-04-05 16:40:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-04-05 16:40:37 -0700
commit80918c065b2a69f9dac00ffb4d4ec17e6c95bbcd (patch)
treec8e19fac6eef1b7420c52fb35fa7d1b1b0cae7d8 /app-shells/fish
parentapp-shells/fish: drop 3.5.1 (diff)
downloadgentoo-80918c065b2a69f9dac00ffb4d4ec17e6c95bbcd.tar.gz
gentoo-80918c065b2a69f9dac00ffb4d4ec17e6c95bbcd.tar.bz2
gentoo-80918c065b2a69f9dac00ffb4d4ec17e6c95bbcd.zip
app-shells/fish: drop 3.6.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-3.6.0.ebuild121
2 files changed, 0 insertions, 122 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 7ddc579f07cb..2acfb6f754bd 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,3 +1,2 @@
DIST fish-3.4.0.tar.xz 3292216 BLAKE2B 3691e5387a8392d7d43b3b0f8b893e83e246c3532684e95a19c7b2eb4ebe80bcf04aaa1b965f5c4f6d782d0ae52269bb1cdafef76845b02f9f99d4c82ea77ce3 SHA512 463ee8d86815520c6de9777fd2b5975f06cc0842137c86cca7ae0331e95d74e755bf6f4b0bdea7e96c11371436ff9f97ce483ae026daa1e8d385f6cad8860ed4
-DIST fish-3.6.0.tar.xz 2892296 BLAKE2B 8c27e091b8241d88bd5e8390a0c221aa6cfccd236ece78feb434760318cf7d4e333a470b53bef02c228916b65ff4e19595cbb21e2021409b50d63df5d133b786 SHA512 a11ea761adace02ef7f88b25893328005cef07f92d362fbc794540dca26e9cfc970878d0312caebd19d64483e9f3c3e24ad6c27dfce264d177f93d65c7ef6996
DIST fish-3.6.1.tar.xz 2866100 BLAKE2B 13a41781c9a7ad093b18d4697c6087ef4c621bdf9cdc23c29ab89514fe990b38461c2323344e884cb95070c98976db1a37615f91281919a4ac36d6ca3312558a SHA512 ee6f5c7699307d515f111c8c4f1633d9eb9703e045a93cfc2fcec722a03cca4ab25e4e09f6fd94ff2d07180d8b37c6ab733323bb2645065fdeb4e94771347597
diff --git a/app-shells/fish/fish-3.6.0.ebuild b/app-shells/fish/fish-3.6.0.ebuild
deleted file mode 100644
index 03c282164a03..000000000000
--- a/app-shells/fish/fish-3.6.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake python-any-r1 readme.gentoo-r1 xdg
-
-DESCRIPTION="Friendly Interactive SHell"
-HOMEPAGE="https://fishshell.com/"
-
-MY_PV="${PV/_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
-else
- SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+doc nls split-usr test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libpcre2-10.32:=[pcre32]
- sys-apps/coreutils
- sys-libs/ncurses:=[unicode(+)]
-"
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
- test? (
- ${PYTHON_DEPS}
- dev-tcltk/expect
- $(python_gen_any_dep '
- dev-python/pexpect[${PYTHON_USEDEP}]
- ')
- )
-"
-# we don't need shpinx dep for release tarballs
-[[ ${PV} == 9999 ]] && DEPEND+=" doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_check_deps() {
- use test || return 0
- python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- # workaround for https://github.com/fish-shell/fish-shell/issues/4883
- if use split-usr; then
- sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
- cmake/Tests.cmake || die
- fi
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- # installing into /bin breaks tests on merged usr systems.
- # sbin -> bin symlink confuses tests.
- # so on split-usr we install to /bin.
- # on merge-usr we set sbindir to bin.
- $(usex split-usr "-DCMAKE_INSTALL_BINDIR=${EPREFIX}/bin" \
- "-DCMAKE_INSTALL_SBINDIR=${EPREFIX}/usr/bin")
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
- -DCURSES_NEED_NCURSES=ON
- -DINSTALL_DOCS="$(usex doc)"
- -DWITH_GETTEXT="$(usex nls)"
- )
- # release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
- if [[ ${PV} == 9999 ]]; then
- mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
- else
- mycmakeargs+=( -DBUILD_DOCS=OFF )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
- readme.gentoo_create_doc
-}
-
-src_test() {
- # some tests are fragile, sanitize environment
- local -x COLUMNS=80
- local -x LINES=24
-
- # very fragile, depends on terminal, size, tmux, screen and timing
- # no die is intentional, for repeated test runs
- if [[ ${PV} != 9999 ]]; then
- rm -v tests/pexpects/terminal.py || :
- fi
-
- # zfs completion test will fail with "Permission denied the ZFS utilities must be run as root."
- mv "${S}"/share/completions/zfs.{fish,disabled} || die
-
- # TODO: fix tests & submit upstream
- # tests are confused by usr/sbin -> bin symlink, no die is intentional for repeated test runs
- use split-usr || rm -v tests/checks/{redirect,type}.fish || :
-
- cmake_build test
-
- # now restore zfs completions
- mv "${S}"/share/completions/zfs.{disabled,fish} || die
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- xdg_pkg_postinst
-}