summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-07 16:15:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-07 16:57:41 +0200
commitaaec6933c7234940551920c043784409c21bbd84 (patch)
treedf1c062429e6b542c37cd2b1547058059348f3da /app-shells/posh-git
parentapp-shells/posh-dotnet: new package; add 1.2.3 (diff)
downloadgentoo-aaec6933c7234940551920c043784409c21bbd84.tar.gz
gentoo-aaec6933c7234940551920c043784409c21bbd84.tar.bz2
gentoo-aaec6933c7234940551920c043784409c21bbd84.zip
app-shells/posh-git: new package; add 1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/posh-git')
-rw-r--r--app-shells/posh-git/Manifest1
-rw-r--r--app-shells/posh-git/metadata.xml14
-rw-r--r--app-shells/posh-git/posh-git-1.1.0.ebuild36
3 files changed, 51 insertions, 0 deletions
diff --git a/app-shells/posh-git/Manifest b/app-shells/posh-git/Manifest
new file mode 100644
index 000000000000..c3b38039f241
--- /dev/null
+++ b/app-shells/posh-git/Manifest
@@ -0,0 +1 @@
+DIST posh-git-1.1.0.tar.gz 90089 BLAKE2B 3759c8382d1e1c48cd5ee40668ae5e3f8edff3ae73861af904a1a4674af52f57e010e2f187813caf728d750b5f492d15860e58a57a24f6e3aa65fa5eb2b7a9cc SHA512 1aa8150c07d212476527c32a8a6acad903811de0068147b43810e3aa897a837c7adf69838195654ca26715ec7e736e56897190b344c6f432374b1d2493e5b891
diff --git a/app-shells/posh-git/metadata.xml b/app-shells/posh-git/metadata.xml
new file mode 100644
index 000000000000..b95ffb970544
--- /dev/null
+++ b/app-shells/posh-git/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/dahlbyk/posh-git/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://gitlab.com/dahlbyk/posh-git/issues/</bugs-to>
+ <remote-id type="github">dahlbyk/posh-git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-git/posh-git-1.1.0.ebuild b/app-shells/posh-git/posh-git-1.1.0.ebuild
new file mode 100644
index 000000000000..72a1c2f7cce4
--- /dev/null
+++ b/app-shells/posh-git/posh-git-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PowerShell environment for Git"
+HOMEPAGE="http://dahlbyk.github.io/posh-git/
+ https://github.com/dahlbyk/posh-git/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dahlbyk/${PN}.git"
+else
+ SRC_URI="https://github.com/dahlbyk/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ virtual/pwsh:*
+ dev-vcs/git
+"
+
+DOCS=( CHANGELOG.md ISSUE_TEMPLATE.md README.md profile.example.ps1 )
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins -r src/.
+
+ einstalldocs
+}