summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-02 18:43:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-02 18:43:52 +0200
commit2ec967b23c34c28c85452a182678ef9b23d9ae11 (patch)
tree325c89690fdd8c40c3fba14c1ae2076536e57260 /app-shells/pwsh-bin
parentapp-shells/pwsh-bin: bump to EAPI 8; minor changes (diff)
downloadgentoo-2ec967b23c34c28c85452a182678ef9b23d9ae11.tar.gz
gentoo-2ec967b23c34c28c85452a182678ef9b23d9ae11.tar.bz2
gentoo-2ec967b23c34c28c85452a182678ef9b23d9ae11.zip
app-shells/pwsh-bin: bump to 7.2.4
Bug: https://bugs.gentoo.org/842564 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/pwsh-bin')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.2.4.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index 21fe429c3986..c2dae793cebd 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -1,3 +1,6 @@
DIST powershell-7.2.1-linux-arm32.tar.gz 66500447 BLAKE2B 2390a26c871abf7012834d8401b6d1afd4c290c7a68794454c2926c782e4ddc20165d1f50718f2ec2b268bcfc2414bc454e211f3bf1eb3c77eb4939e52b7d846 SHA512 29f6c1a926c8cff6386e4d98ce91ec4ff91c19d0cd4cacdc8d3da1c65858841695a466e0a1c9106df6da1fa7d79ac96de023e564be6ba1ac00d5c94216380ed8
DIST powershell-7.2.1-linux-arm64.tar.gz 65023197 BLAKE2B 8acd526537695e29d44d4e7445dd4fce1c0b2bb8a2cda57c353d7e21aac4efe85aa9e6752d71afb276f5035d0951e5f5684ea88751a25848387e4d5ea37d36a5 SHA512 094659aa63e2f4728997eaa086f1a74f34eb4876f1e679cb595a0c07c4133b42fbeb45fafbd3b916df8529a63fe98e2ffc54b0de66f3c8d17d9d72e03d35f0b8
DIST powershell-7.2.1-linux-x64.tar.gz 69668637 BLAKE2B c173216df2147e5f857533cf35a6adaafe8e34f3b475bab6696c09f118ea62fd8304f25bbcfc9ef07807aee87f44ed0829d170ca878039a3ade5853235b61e82 SHA512 63a84dae492c0f1ef13629a50bf5b33fa9d5dd8d0d878a2e1dce185b398ef39467498ae7ea75b78326fb4c669fa77bea0549280fb6669e28cb0191a48fc374de
+DIST powershell-7.2.4-linux-arm32.tar.gz 66241774 BLAKE2B 6a37a929b3f315c00fa4da97d9a3a1f394224a35d03121b610b46de765dbf20ecbc6603250245fa4b07e666761a48a61c172ebb7e5d36f027ef7e985d4ac2734 SHA512 9d87bd111e6513f0771632bd6ae656d8a6488427707875b85c0b28cced5a2879a0c311a48e280dd9947ac767fed3ecc916441b04cf29bd80467715411858e899
+DIST powershell-7.2.4-linux-arm64.tar.gz 64769626 BLAKE2B 855daf5f18f5e5645d0efadc5b6db06175f9650f215c6e76a4348081685d368b93abd3cab145593074899c5ecd4b4f622bb0a3730181ccf2137d9b08a4b0ed4e SHA512 a1538b3a12824ffde0d75e5a0e047d0d39fd697ecac691285c39656a7e507fb0ca02d5fa2594d575cda70b1b1ff858f157f1160fc7320d3d342fe226ea67d7c6
+DIST powershell-7.2.4-linux-x64.tar.gz 69406638 BLAKE2B b7676de3c23417d92b7540754d94dbefa829d98ddedc4045de2b220bebc54a44fddc59538f6cfaaea69e67d5d46d67767c446777b29d22654b8e26858c29a6c0 SHA512 748c0459f00d52066c6da38bff88d03a25fcf65a9a9318614fd21f4984da8e459e0c0461663f23dd716fb285bbfeb406b88f6cf30aa9dd3eb356b2a850792f45
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.2.4.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.2.4.ebuild
new file mode 100644
index 000000000000..c78be49848d4
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://powershell.org/"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}