summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-20 23:55:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-21 00:47:22 +0200
commitaaaa89249423c199bfa2a8245088388fdb3994fd (patch)
treed1e7542d11d5761c69daaf8159d4abfd9999a5f0 /app-shells/pwsh-bin
parentapp-backup/rdiff-backup: add 2.2.6 (diff)
downloadgentoo-aaaa89249423c199bfa2a8245088388fdb3994fd.tar.gz
gentoo-aaaa89249423c199bfa2a8245088388fdb3994fd.tar.bz2
gentoo-aaaa89249423c199bfa2a8245088388fdb3994fd.zip
app-shells/pwsh-bin: bump to 7.3.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/pwsh-bin')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild69
2 files changed, 72 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index d5f4cdebe768..9f47fd11d45e 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -4,3 +4,6 @@ DIST powershell-7.3.1-linux-x64.tar.gz 71616643 BLAKE2B 16ecc1211f796f92d5cf64ac
DIST powershell-7.3.6-linux-arm32.tar.gz 66514877 BLAKE2B 3ea314d0353e5688bcf51288271da472cc3120436779cfee6a248646e82b9730a6136da12daf1127777232b559d81306f50aac006e5c50fb0375a63f9c4f1de9 SHA512 a97f9a34d64d46664bca1c3963858bdcc84d6e6a67c81df8398faf134d86f459466f0b27f969ab18a1158c60eb7652a49106a654ff3ca5bb296e5d4093df771b
DIST powershell-7.3.6-linux-arm64.tar.gz 65416423 BLAKE2B dd3855a9e092092930761ef1db9b5fdad523ced69943c57827980e483b61b21229043638c3e620f76827167905d61f23f240a8b128a294197e457ed4a478ace4 SHA512 7a2c1c7ead3cbda7edf6672a241c7f8368ca58b44d1baa634b28a278c154a75bc1f0bc14a0945fcc3dadfe21c1518577901dc765659476856be3575768a161a8
DIST powershell-7.3.6-linux-x64.tar.gz 68984703 BLAKE2B 36df952abcf1bc116a4a0734313877ae432120b77fe36e6fe68d6db164f6a73809a6f494169e3a4515594356f1d2812379524c6b6c1d90ba4429d87b570ee95c SHA512 da2d19fef2dc056f5012c1e8e3a027f0c3b6fb35f1d5d4bb0a17dc8ddbc015c38269c5b4459a56280bf3191d85bf4513b53d51ea3202bf071df439374a5a5870
+DIST powershell-7.3.7-linux-arm32.tar.gz 66617447 BLAKE2B be80d24a4cda6a59ca220c8a05c9a0c9b9770720f5f8db3184b120edb92f4d1a52f4d59328ff0b821e835aed55cc69d9191ee64913db0d8a1aa3f0ac62f82051 SHA512 49d81476d4d4aa7a1138b605baaadcdecbbfd768161c1cc7f0f448dd8038e55dca71290f3e3842ed526b18df7b5e4ac959f13eea04584e11a6a0f2de1af9c711
+DIST powershell-7.3.7-linux-arm64.tar.gz 65519990 BLAKE2B 133264c94d0103faa14f65744abfc7837fe09bf878c85d50b7bc949bb784c6df3e8dc15a674c0c72cc1e91a8499e79a44cd8608affa5b7a2b8d46fa82cd74275 SHA512 fd7530a8ae6a81d13193f8e9da46ef598b5e0e13054f63350c8cf6d41bccff0764566eff6114287da88c2de0ed5b3e37cfc104547528b060a0a217420e0ac889
+DIST powershell-7.3.7-linux-x64.tar.gz 69092859 BLAKE2B 9db34b8dd6f5254a8f8f2a87daa72cb8e3f12aecb5f9967f7e21646dad4a6af61bedf3387cc9eaf12382d1fe899195a294b59f6e63d43fb0f701bc2973aa82d5 SHA512 42e148a737afed971e61929e8315d59e1f6a118fc8f2982b0bf0a1d05d73628e99d77d4b4b12b99805f40e9c2425e8bf9dfae2fc7fd04b5b8ba4de236df1cd8f
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild
new file mode 100644
index 000000000000..94b1b6ce19ec
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="app-eselect/eselect-pwsh"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}