summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-11 01:04:14 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-11 02:19:36 +0200
commitcf9b68b0d67394d255792e4d302c9a96715361ff (patch)
treed64701005e2bdf8984e1d237fe3e9655db8563f4 /app-shells/pwsh-bin
parentapp-shells/pwsh: fix Gentoo-managed PSModulePath (diff)
downloadgentoo-cf9b68b0d67394d255792e4d302c9a96715361ff.tar.gz
gentoo-cf9b68b0d67394d255792e4d302c9a96715361ff.tar.bz2
gentoo-cf9b68b0d67394d255792e4d302c9a96715361ff.zip
app-shells/pwsh-bin: fix Gentoo-managed PSModulePath
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/pwsh-bin')
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.3.6-r1.ebuild (renamed from app-shells/pwsh-bin/pwsh-bin-7.3.6.ebuild)2
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.3.7-r1.ebuild (renamed from app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.3.6.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.3.6-r1.ebuild
index 8b0cee74b025..748d3db6ec06 100644
--- a/app-shells/pwsh-bin/pwsh-bin-7.3.6.ebuild
+++ b/app-shells/pwsh-bin/pwsh-bin-7.3.6-r1.ebuild
@@ -56,7 +56,7 @@ src_install() {
fperms 0755 "${dest_root}/pwsh"
- local gentoo_path='PSModulePath="${PSModulePath}:/usr/share/GentooPowerShell/Modules:"'
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
}
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.3.7-r1.ebuild
index 94b1b6ce19ec..d5dc3e03bc4a 100644
--- a/app-shells/pwsh-bin/pwsh-bin-7.3.7.ebuild
+++ b/app-shells/pwsh-bin/pwsh-bin-7.3.7-r1.ebuild
@@ -56,7 +56,7 @@ src_install() {
fperms 0755 "${dest_root}/pwsh"
- local gentoo_path='PSModulePath="${PSModulePath}:/usr/share/GentooPowerShell/Modules:"'
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
}