summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-17 19:19:37 +0000
committerSam James <sam@gentoo.org>2022-07-17 19:30:31 +0000
commitd053de83dc6c8b5f670f2c219ddf8129b7064986 (patch)
treeb775a54af00ba5664b2d13de0c7b72d41703e61b /app-shells/rush
parentapp-emacs/emacs-bazel-mode: new package; add version 0_p20220707 (diff)
downloadgentoo-d053de83dc6c8b5f670f2c219ddf8129b7064986.tar.gz
gentoo-d053de83dc6c8b5f670f2c219ddf8129b7064986.tar.bz2
gentoo-d053de83dc6c8b5f670f2c219ddf8129b7064986.zip
app-shells/rush: add 2.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/rush')
-rw-r--r--app-shells/rush/Manifest1
-rw-r--r--app-shells/rush/rush-2.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/rush/Manifest b/app-shells/rush/Manifest
index 437c8e4ad695..bde4cc1d0a78 100644
--- a/app-shells/rush/Manifest
+++ b/app-shells/rush/Manifest
@@ -1,2 +1,3 @@
DIST rush-2.1.tar.xz 811160 BLAKE2B 88cd95da8b3ec03f52bc9a38e44091051f5b7daaa7a49c630f6ad30c5c6e3945ec69225dddcdfacefdbe9aa39e654fc65965af2c5925848c61975413692f95ec SHA512 388439a5436429eb0ed35009b8828a14566fd2e3671eea5e4d88285058084e5c921088824cb3626d755d1af4ad83a3edd39648173f0f0bafdc5b8751e94524aa
DIST rush-2.2.tar.xz 815380 BLAKE2B 90858039d428233af389aa3d63b8b40c3415210b0145a524e7b18ec4f348f8694f0d6794f2646669c6742da3a7d85c3931ac3a65d4d3fb57d1d8be945d84cc10 SHA512 aab8ddf2eaacee6a94ad0388376d5703f96e8dcbe794bf38e7961527448b998450cd51b7593d2b1424c274a6cef273ae0c194e446871bb446beea31f2b5c8144
+DIST rush-2.3.tar.xz 814844 BLAKE2B 90e91165814def09dd7c795601529df96dac3fbeee06bcbc232fcb59741f455a7916092d7f1794fa4f85ba707534683772c508fc6b75318d6cd7c68c9880b972 SHA512 d563219f89b23f50fc30143336e0f602d4b585a07110ed6bb194600c92756ade4b4e90b098998c2de0003418c1f0e9a7879d847d543e534b4f8253c7add50db9
diff --git a/app-shells/rush/rush-2.3.ebuild b/app-shells/rush/rush-2.3.ebuild
new file mode 100644
index 000000000000..7bd9b3017931
--- /dev/null
+++ b/app-shells/rush/rush-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="https://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ # These tests see SANDBOX_* variables and fail as a result, bug #689554
+ for file in tests/{eval,clr,unset,keep,set}env.at tests/legacy/env.at ; do
+ echo > ${file} || die
+ done
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}