summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-03 13:32:55 +0100
committerSam James <sam@gentoo.org>2024-05-03 13:33:22 +0100
commit5635a24b44a19a8a762d20554ff58da9e041b37b (patch)
treedb33c64dc9568bf18ad98dd5f3bea92931884a35 /app-text
parentsys-auth/polkit: fix tests (diff)
downloadgentoo-5635a24b44a19a8a762d20554ff58da9e041b37b.tar.gz
gentoo-5635a24b44a19a8a762d20554ff58da9e041b37b.tar.bz2
gentoo-5635a24b44a19a8a762d20554ff58da9e041b37b.zip
app-text/tree: drop homebrew bash-completion
>=app-shells/bash-completion-2.13.0 installs its own superior one, so go for that, rather than an old Gentoo-local one. Bug: https://bugs.gentoo.org/931129 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tree/tree-2.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/tree/tree-2.1.1-r1.ebuild b/app-text/tree/tree-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..1fb745f40e2f
--- /dev/null
+++ b/app-text/tree/tree-2.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
+SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+S=${WORKDIR}/unix-${P}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+}