summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-05-07 00:58:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-05-07 01:05:10 +0200
commit71c924b5724524e4f3b97b538a69865345e867ae (patch)
treeb05b2c5d3eabeb781757db6e42bd9492e6647c40 /app-text
parentapp-text/openpaperwork-core: drop 2.1.2 (diff)
downloadgentoo-71c924b5724524e4f3b97b538a69865345e867ae.tar.gz
gentoo-71c924b5724524e4f3b97b538a69865345e867ae.tar.bz2
gentoo-71c924b5724524e4f3b97b538a69865345e867ae.zip
app-text/openpaperwork-core: add 2.2.2
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/openpaperwork-core/Manifest1
-rw-r--r--app-text/openpaperwork-core/openpaperwork-core-2.2.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/openpaperwork-core/Manifest b/app-text/openpaperwork-core/Manifest
index ceeb584657d8..8a0714583212 100644
--- a/app-text/openpaperwork-core/Manifest
+++ b/app-text/openpaperwork-core/Manifest
@@ -1 +1,2 @@
DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
+DIST paperwork-2.2.2.tar.bz2 2531134 BLAKE2B 760d5fdc949ed44993c9845232e3f92b26b8dcb84ef82b08be7dbb0b262461feaf06f930f3fce0b94fdd8412a8264969bac117e3ea7aef70e1b47436a9dba3c0 SHA512 e0d3c24a0d611ffea231e129461d2925dc8318aaade185e83361bca8d1757e4601510db6122dc412863e617a387eb1c6008d0974c2b37be7ac4e4c3e68bc450b
diff --git a/app-text/openpaperwork-core/openpaperwork-core-2.2.2.ebuild b/app-text/openpaperwork-core/openpaperwork-core-2.2.2.ebuild
new file mode 100644
index 000000000000..f921425cccd0
--- /dev/null
+++ b/app-text/openpaperwork-core/openpaperwork-core-2.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core part of Paperwork (plugin management)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/distro[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-apps/which
+ sys-devel/gettext"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}