summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-02 11:21:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-02 12:25:51 -0500
commit7e149b5feeef9e7db5b3afebc0238a05f244869c (patch)
tree08906f5cbec530c43f2210917316b2c67e4820d9 /dev-games/godot
parentdev-games/godot: drop 4.0_beta15 (diff)
downloadgentoo-7e149b5feeef9e7db5b3afebc0238a05f244869c.tar.gz
gentoo-7e149b5feeef9e7db5b3afebc0238a05f244869c.tar.bz2
gentoo-7e149b5feeef9e7db5b3afebc0238a05f244869c.zip
dev-games/godot: add 4.0_beta17
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games/godot')
-rw-r--r--dev-games/godot/Manifest1
-rw-r--r--dev-games/godot/files/godot-4.0_beta17-no-deprecated-fix.patch51
-rw-r--r--dev-games/godot/godot-4.0_beta17.ebuild241
3 files changed, 293 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 06dd3e2f3ce4..7b19a1782cc3 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,2 +1,3 @@
DIST godot-3.5.1-stable.tar.xz 24153448 BLAKE2B 9d61276a2d82ef4f4487ec1046b7fa58f2b3626640b2db25c1f98c3f8e2ff40eddcf943fd9ffaaf6814fbafbbe7ef1d3f642d77af953b87731cff570ac3a5473 SHA512 59e5ca88534f542562971efb83b76561705f9ca8761311f01b4453857e7ae046c17cadd0d5ca6f6f56e262b5031294a8b9ad970fa6ffc95e1a6a1e1bae48d55f
DIST godot-4.0-beta16.tar.xz 31937624 BLAKE2B 998edcd6d9f118cb96a4f84b81b73c36d060d297702fa2a9dc4be936c7ca9aa35b77db16caf5ed19662fcae700f59e329393a17fd88448d8a6ff8f484a136f9c SHA512 c9cf5b66675dfe9253852eee7748a5c2bd04f356524def6e9925bef73baee3239f9f9405a92d373dcadbaff7c3288e54e547ae3cb46974bea61bfb68576b7c13
+DIST godot-4.0-beta17.tar.xz 31965968 BLAKE2B 897153aa9b36ccb7aea29749534e7a04452cd24ef5e8404063a1f96c6b61633d3f175279f08e49bbc6479a9df0f0ffe7cf4030d483502af7a90cc5cdd24f4010 SHA512 1a0a74a3538947cc3942fdbc27e941e8fe1b4424b257444176ea19fb6db3cc6c374f24190d1779a530cb61b5e42ff242842692d0878280862c5644e9de93d5c9
diff --git a/dev-games/godot/files/godot-4.0_beta17-no-deprecated-fix.patch b/dev-games/godot/files/godot-4.0_beta17-no-deprecated-fix.patch
new file mode 100644
index 000000000000..8c4a14edc4bb
--- /dev/null
+++ b/dev-games/godot/files/godot-4.0_beta17-no-deprecated-fix.patch
@@ -0,0 +1,51 @@
+Backport to fix build with USE=-deprecated
+
+https://github.com/godotengine/godot/commit/c197b398c38727c6cce3d2fec7aa07d2e1020e09
+From: =?UTF-8?q?R=C3=A9mi=20Verschelde?= <rverschelde@gmail.com>
+Date: Wed, 1 Feb 2023 22:29:33 +0100
+Subject: [PATCH] Fix build with `deprecated=no` not exclude
+ ProjectConverter3To4 options
+
+Fixes #72520.
+--- a/main/main.cpp
++++ b/main/main.cpp
+@@ -2366,8 +2366,10 @@ bool Main::start() {
+ String _export_preset;
+ bool export_debug = false;
+ bool export_pack_only = false;
++#ifndef DISABLE_DEPRECATED
+ bool converting_project = false;
+ bool validating_converting_project = false;
++#endif // DISABLE_DEPRECATED
+ #endif
+
+ main_timer_sync.init(OS::get_singleton()->get_ticks_usec());
+@@ -2383,10 +2385,12 @@ bool Main::start() {
+ #ifdef TOOLS_ENABLED
+ } else if (args[i] == "--no-docbase") {
+ doc_base = false;
++#ifndef DISABLE_DEPRECATED
+ } else if (args[i] == "--convert-3to4") {
+ converting_project = true;
+ } else if (args[i] == "--validate-conversion-3to4") {
+ validating_converting_project = true;
++#endif // DISABLE_DEPRECATED
+ } else if (args[i] == "-e" || args[i] == "--editor") {
+ editor = true;
+ } else if (args[i] == "-p" || args[i] == "--project-manager") {
+@@ -2547,6 +2551,7 @@ bool Main::start() {
+ return false;
+ }
+
++#ifndef DISABLE_DEPRECATED
+ if (converting_project) {
+ int exit_code = ProjectConverter3To4(converter_max_kb_file, converter_max_line_length).convert();
+ OS::get_singleton()->set_exit_code(exit_code);
+@@ -2557,6 +2562,7 @@ bool Main::start() {
+ OS::get_singleton()->set_exit_code(exit_code);
+ return false;
+ }
++#endif // DISABLE_DEPRECATED
+
+ #endif
+
diff --git a/dev-games/godot/godot-4.0_beta17.ebuild b/dev-games/godot/godot-4.0_beta17.ebuild
new file mode 100644
index 000000000000..712797804adc
--- /dev/null
+++ b/dev-games/godot/godot-4.0_beta17.ebuild
@@ -0,0 +1,241 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 desktop optfeature python-any-r1
+inherit scons-utils toolchain-funcs xdg
+
+MY_P="${PN}-$(ver_rs 2 -)"
+
+DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
+HOMEPAGE="https://godotengine.org/"
+SRC_URI="https://downloads.tuxfamily.org/godotengine/$(ver_rs 2 /)/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="
+ MIT
+ AFL-2.1 Apache-2.0 BSD Boost-1.0 CC0-1.0 LGPL-2.1+ Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )"
+SLOT="4"
+KEYWORDS="~amd64"
+# Enable roughly same as upstream by default so it works as expected,
+# except raycast (tools-only heavy dependency), and deprecated.
+IUSE="debug deprecated +gui raycast +runner test +theora +tools +upnp +vulkan +webp"
+# disable tests until out of beta, tests themselves are new and can be volatile
+RESTRICT="test"
+
+# dlopen: libX*,libglvnd
+RDEPEND="
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli,harfbuzz]
+ media-libs/harfbuzz:=[icu]
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libvorbis
+ <net-libs/mbedtls-3:=
+ net-libs/wslay
+ sys-libs/zlib:=
+ gui? (
+ media-libs/libglvnd[X]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ tools? ( raycast? ( media-libs/embree:3 ) )
+ vulkan? ( media-libs/vulkan-loader[X] )
+ )
+ theora? ( media-libs/libtheora )
+ tools? ( app-misc/ca-certificates )
+ upnp? ( net-libs/miniupnpc:= )
+ webp? ( media-libs/libwebp:= )"
+DEPEND="
+ ${RDEPEND}
+ tools? ( test? ( dev-cpp/doctest ) )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0-musl.patch
+ "${FILESDIR}"/${PN}-4.0_beta3-headless-header.patch
+ "${FILESDIR}"/${PN}-4.0_beta8-scons.patch
+ "${FILESDIR}"/${P}-no-deprecated-fix.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
+ sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
+ sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
+ -i misc/dist/linux/org.godotengine.Godot.desktop || die
+
+ sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/linuxbsd/detect.py || die
+
+ # use of builtin_ switches can be messy (see below), delete to be sure
+ local unbundle=(
+ doctest embree freetype graphite harfbuzz icu4c libogg
+ libpng libtheora libvorbis libwebp mbedtls miniupnpc
+ pcre2 recastnavigation volk wslay zlib zstd
+ # certs: unused by generated header, but scons panics if not found
+ # linuxbsd_headers: would /want/ to unbundle these, but it is rather
+ # messy given godot has dropped all the pkg-config calls and uses
+ # hardcoded paths on top -- on the plus side, removes a real need
+ # to have IUSE="alsa dbus fontconfig pulseaudio speech udev" (dlopen)
+ )
+ rm -r "${unbundle[@]/#/thirdparty/}" || die
+
+ # do symlinks to avoid too much patching with hardcoded header paths
+ mkdir thirdparty/lib{vorbis,ogg} || die
+ ln -s "${ESYSROOT}"/usr/include thirdparty/zstd || die
+ ln -s "${ESYSROOT}"/usr/include/doctest thirdparty/ || die
+ ln -s "${ESYSROOT}"/usr/include/ogg thirdparty/libogg/ || die
+ ln -s "${ESYSROOT}"/usr/include/vorbis thirdparty/libvorbis/ || die
+}
+
+src_compile() {
+ local -x GODOT_VERSION_STATUS=$(ver_cut 3-4) # for dev versions only
+ local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
+
+ local esconsargs=(
+ AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ progress=no
+ verbose=yes
+
+ deprecated=$(usex deprecated)
+ #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
+ opengl3=$(usex gui)
+ use_volk=no # unnecessary when linking directly to libvulkan
+ vulkan=$(usex gui $(usex vulkan))
+ x11=$(usex gui)
+
+ system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+
+ # platform/*/detect.py uses builtin_* switches to check if need
+ # to link with system libraries, but ignores whether the dep is
+ # actually used, so "enable" deleted builtins on disabled deps
+ builtin_certs=no
+ builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
+ builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
+ builtin_freetype=no
+ builtin_glslang=yes #879111
+ builtin_graphite=no
+ builtin_harfbuzz=no
+ builtin_icu=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex !theora)
+ builtin_libvorbis=no
+ builtin_libwebp=$(usex !webp)
+ builtin_mbedtls=no
+ builtin_miniupnpc=$(usex !upnp)
+ builtin_msdfgen=yes # not wired for unbundling nor packaged
+ builtin_pcre2=no
+ builtin_recast=no
+ builtin_rvo2=yes # bundled copy has godot-specific changes
+ builtin_squish=yes # ^ likewise, may not be safe to unbundle
+ builtin_wslay=no
+ builtin_xatlas=yes # not wired for unbundling nor packaged
+ builtin_zlib=no
+ builtin_zstd=no
+ # (more is bundled in third_party/ but they lack builtin_* switches)
+
+ # modules with optional dependencies, "possible" to disable more but
+ # gets messy and breaks all sorts of features (expected enabled)
+ module_gridmap_enabled=$(usex deprecated) # fails without deprecated
+ module_mono_enabled=no # unhandled
+ # note raycast is only enabled on amd64+arm64, see raycast/config.py
+ module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_webp_enabled=$(usex webp)
+
+ # let *FLAGS handle these, e.g. can pass -flto as-is
+ debug_symbols=no
+ lto=none
+ optimize=custom
+ use_static_cpp=no
+ )
+
+ if use runner && use tools; then
+ # build alternate faster + ~60% smaller binary for running
+ # games or servers without game development debug paths
+ escons extra_suffix=runner target=template_release "${esconsargs[@]}"
+ fi
+
+ esconsargs+=(
+ target=$(usex tools editor template_$(usex debug{,} release))
+ dev_build=$(usex debug)
+
+ # harmless but note this bakes in --test in the final binary
+ tests=$(usex tools $(usex test))
+ )
+
+ escons extra_suffix=main "${esconsargs[@]}"
+}
+
+src_test() {
+ xdg_environment_reset
+ bin/godot*.main --headless --test || die
+}
+
+src_install() {
+ local s=godot${SLOT}
+
+ newbin bin/godot*.main ${s}
+ if use runner && use tools; then
+ newbin bin/godot*.runner ${s}-runner
+ else
+ # always available, revdeps shouldn't depend on [runner]
+ dosym ${s} /usr/bin/${s}-runner
+ fi
+
+ newman misc/dist/linux/godot.6 ${s}.6
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+
+ if use gui; then
+ newicon icon.svg ${s}.svg
+ newmenu misc/dist/linux/org.godotengine.Godot.desktop \
+ org.godotengine.${s^}.desktop
+
+ insinto /usr/share/metainfo
+ newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
+ org.godotengine.${s^}.appdata.xml
+
+ insinto /usr/share/mime/application
+ newins misc/dist/linux/org.godotengine.Godot.xml \
+ org.godotengine.${s^}.xml
+ fi
+
+ newbashcomp misc/dist/shell/godot.bash-completion ${s}
+ bashcomp_alias ${s}{,-runner}
+
+ insinto /usr/share/fish/vendor_completions.d
+ newins misc/dist/shell/godot.fish ${s}.fish
+ dosym ${s}.fish /usr/share/fish/vendor_completions.d/${s}-runner.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins misc/dist/shell/_godot.zsh-completion _${s}
+ dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # these use bundled headers then get dlopen()'ed if available, USE=gui
+ # itself could technically be a optfeature too but it'd be messy here
+ if use gui; then
+ optfeature "gamepad connection detection support" virtual/libudev
+ optfeature "screensaver and portal desktop handling" sys-apps/dbus
+ optfeature "sound support" media-libs/alsa-lib media-libs/libpulse
+ fi
+ optfeature "system fonts support" media-libs/fontconfig
+ optfeature "text-to-speech support" app-accessibility/speech-dispatcher
+}