summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-21 06:38:06 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-21 07:16:09 -0500
commita079caaa459df1b3661baf5a188e52e02af8bbdc (patch)
treef238471c7efec32182beb55b02659710633ff555 /dev-games/godot
parentmail-client/thunderbird: stabilize 102.8.0 for amd64 (diff)
downloadgentoo-a079caaa459df1b3661baf5a188e52e02af8bbdc.tar.gz
gentoo-a079caaa459df1b3661baf5a188e52e02af8bbdc.tar.bz2
gentoo-a079caaa459df1b3661baf5a188e52e02af8bbdc.zip
dev-games/godot: backport gcc13 build fix
Well, backport from the thirdparty's upstream, godot itself still needs to update. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games/godot')
-rw-r--r--dev-games/godot/files/godot-4.0_rc2-gcc13.patch21
-rw-r--r--dev-games/godot/godot-4.0_rc2.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-games/godot/files/godot-4.0_rc2-gcc13.patch b/dev-games/godot/files/godot-4.0_rc2-gcc13.patch
new file mode 100644
index 000000000000..124e4b56a9d0
--- /dev/null
+++ b/dev-games/godot/files/godot-4.0_rc2-gcc13.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/895706
+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/commit/29d492b60c8
+From: Adam Sawicki <adam.sawicki@amd.com>
+Date: Thu, 19 Jan 2023 13:19:55 +0100
+Subject: [PATCH] Added missing #include <cstdio>
+
+For snprintf, for compatibility with GCC 13.
+Fixes #312 - thanks @marxin !
+--- a/thirdparty/vulkan/vk_mem_alloc.h
++++ b/thirdparty/vulkan/vk_mem_alloc.h
+@@ -2614,6 +2614,10 @@ VMA_CALL_PRE void VMA_CALL_POST vmaFreeStatsString(
+ #include <bit> // For std::popcount
+ #endif
+
++#if VMA_STATS_STRING_ENABLED
++ #include <cstdio> // For snprintf
++#endif
++
+ /*******************************************************************************
+ CONFIGURATION SECTION
+
diff --git a/dev-games/godot/godot-4.0_rc2.ebuild b/dev-games/godot/godot-4.0_rc2.ebuild
index d031d3f1fcaf..d2601d52d4ff 100644
--- a/dev-games/godot/godot-4.0_rc2.ebuild
+++ b/dev-games/godot/godot-4.0_rc2.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0_beta3-headless-header.patch
"${FILESDIR}"/${PN}-4.0_beta8-scons.patch
"${FILESDIR}"/${PN}-4.0_rc2-musl.patch
+ "${FILESDIR}"/${PN}-4.0_rc2-gcc13.patch
)
src_prepare() {