summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 19:35:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 19:40:33 +0200
commit2ced313913e1150158de9d6ac7dc1a6494b52cf3 (patch)
tree01420e2605cf3bb06865b28b901f9a65206f92af /dev-libs
parentdev-libs/qtkeychain: add 0.14.3 (diff)
downloadgentoo-2ced313913e1150158de9d6ac7dc1a6494b52cf3.tar.gz
gentoo-2ced313913e1150158de9d6ac7dc1a6494b52cf3.tar.bz2
gentoo-2ced313913e1150158de9d6ac7dc1a6494b52cf3.zip
dev-libs/appstream: drop 0.15.6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-0.15.6.ebuild77
-rw-r--r--dev-libs/appstream/files/appstream-0.15.6-disable-Werror-flags.patch46
3 files changed, 0 insertions, 124 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index 14e5aa16b233..460e8ece43db 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,3 +1,2 @@
-DIST AppStream-0.15.6.tar.xz 2517688 BLAKE2B 09519205c7dfc5f0715b9d5ae7e99a67673ab499f1e2cb39815edde64defc1aa5059215575278bbcfc4482cd385a79e081c70f6acea3c446c5869dc6b2e18f6c SHA512 7426bc89e22b751de7b3e27d7c07eb1c373f4439f9966868ce5ea410d209b8c5292e03695a34b7a49bfa61e2e62265c7f7cdffc0be871c950193c933f65757ef
DIST AppStream-0.16.4.tar.xz 2570176 BLAKE2B ac051b846fd1c7b0cbb3429e0b4c3f81027cddb35ee6bcd5e9d38a09d937abcc37ac4908f68ec55404ae852fd146b4e749832d3ac96443458e86cfe506a6fed4 SHA512 e3a9fc423fe5a2baaaa002871566f320ecd6dbd3a01ab24221afe9b93a69e9afb6bed6d7772c434376501803dc7b2c80b79eda849fcaf4748f9f24a5908a22a8
DIST AppStream-1.0.2.tar.xz 2629708 BLAKE2B eb31e675cea1c8b9357227c851bdd24f9cb949e232089380a8727630ab8055f0de6bebd74f70f3c1cf84e5420b9d4fef681671a0e4e97265af26d594b2874c48 SHA512 e5c109c383e3bf3af3693bfb3146663767c2c61fac0bd421f2ce52242fe7b869effeacc4d207987321dfeb4ab0ba77ece6c1c6eea054a7365204cd955426517a
diff --git a/dev-libs/appstream/appstream-0.15.6.ebuild b/dev-libs/appstream/appstream-0.15.6.ebuild
deleted file mode 100644
index 22035505fdee..000000000000
--- a/dev-libs/appstream/appstream-0.15.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson xdg-utils
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ximion/${PN}"
-else
- MY_PN="AppStream"
- SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
-HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-# check as_api_level
-SLOT="0/4"
-IUSE="apt doc +introspection qt5 test"
-RESTRICT="test" # bug 691962
-
-RDEPEND="
- >=dev-libs/glib-2.62:2
- dev-libs/libxml2:2
- >=dev-libs/libxmlb-0.3.6:=
- dev-libs/libyaml
- dev-libs/snowball-stemmer:=
- >=net-misc/curl-7.62
- introspection? ( >=dev-libs/gobject-introspection-1.56:= )
- qt5? ( dev-qt/qtcore:5 )
-"
-DEPEND="${RDEPEND}
- test? ( qt5? ( dev-qt/qttest:5 ) )
-"
-BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxslt
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- doc? ( app-text/docbook-xml-dtd:4.5 )
- test? ( dev-qt/linguist-tools:5 )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-disable-Werror-flags.patch ) # bug 733774
-
-src_prepare() {
- default
- sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
- if ! use test; then
- sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
- fi
-}
-
-src_configure() {
- xdg_environment_reset
-
- local emesonargs=(
- -Dapidocs=false
- -Ddocs=false
- -Dcompose=false
- -Dmaintainer=false
- -Dstatic-analysis=false
- -Dstemming=true
- -Dvapi=false
- -Dapt-support=$(usex apt true false)
- -Dinstall-docs=$(usex doc true false)
- -Dgir=$(usex introspection true false)
- -Dqt=$(usex qt5 true false)
- )
-
- meson_src_configure
-}
diff --git a/dev-libs/appstream/files/appstream-0.15.6-disable-Werror-flags.patch b/dev-libs/appstream/files/appstream-0.15.6-disable-Werror-flags.patch
deleted file mode 100644
index ca50493e4fd6..000000000000
--- a/dev-libs/appstream/files/appstream-0.15.6-disable-Werror-flags.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/meson.build 2022-12-22 23:48:12.000000000 +0100
-+++ b/meson.build 2022-12-24 22:15:49.620891586 +0100
-@@ -95,43 +95,6 @@
- endif
- endif
-
--# a few compiler warning flags we always want enabled
--add_project_arguments(
-- cc.get_supported_arguments([
-- '-Werror=shadow',
-- '-Werror=empty-body',
-- '-Werror=strict-prototypes',
-- '-Werror=missing-prototypes',
-- '-Werror=implicit-function-declaration',
-- '-Werror=pointer-arith',
-- '-Werror=missing-declarations',
-- '-Werror=return-type',
-- '-Werror=int-conversion',
-- '-Werror=incompatible-pointer-types',
-- '-Werror=misleading-indentation',
-- '-Werror=missing-include-dirs',
-- '-Werror=declaration-after-statement',
-- '-Werror=format-security',
--
-- '-Wno-missing-field-initializers',
-- '-Wno-error=missing-field-initializers',
-- '-Wno-unused-parameter',
-- '-Wno-error=unused-parameter',
-- ]),
-- language: 'c'
--)
--add_project_arguments(
-- '-Wno-unused-parameter',
-- '-Werror=shadow',
-- '-Werror=empty-body',
-- '-Werror=pointer-arith',
-- '-Werror=init-self',
-- '-Werror=missing-declarations',
-- '-Werror=return-type',
-- '-Werror=misleading-indentation',
-- '-Werror=format-security',
-- language: 'cpp'
--)
- add_project_arguments('-DAS_COMPILATION', language: 'c')
-
- # Vendor extensions in system headers